summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Rizzitello2020-12-22 22:06:48 -0500
committerChris Rizzitello2020-12-22 22:06:48 -0500
commitb0db90dbc0fbeb292342ad7128eac02c927053ee (patch)
treeb99bfd803f75a21774f4f3daa51a056e6cefeb06
downloadaur-qtsconverter.tar.gz
Initial Commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD28
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c6530b69dd2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = qtsconverter
+ pkgdesc = A Tool to convert ts < == > csv or xlsx
+ pkgver = 4.3.4
+ pkgrel = 1
+ url = https://github.com/guerinoni/qTsConverter
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ depends = qt5-base
+ depends = qt5-declarative
+ provides = qtsconverter
+ conflicts = qtsconverter-git
+ source = git://github.com/guerinoni/qTsConverter.git#tag=4.3.4
+ md5sums = SKIP
+
+pkgname = qtsconverter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15f5f0da515c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Chris Rizzitello <sithlord48@gmail.com>
+pkgname=qtsconverter
+pkgver=4.3.4
+pkgrel=1
+provides=('qtsconverter')
+conflicts=('qtsconverter-git')
+pkgdesc="A Tool to convert ts < == > csv or xlsx"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/guerinoni/qTsConverter"
+license=('MIT')
+makedepends=('cmake' 'git')
+depends=('qt5-base' 'qt5-declarative') #Qt5)
+#optdepends=('otf-ipafont: font for displaying japanese')
+source=('git://github.com/guerinoni/qTsConverter.git#tag=4.3.4')
+md5sums=(SKIP)
+
+build() {
+ cd "qTsConverter"
+ git submodule init
+ git submodule update
+ cmake -DSTATIC_LIB=OFF -DCMAKE_INSTALL_PREFIX=/usr CMakeLists.txt
+ make
+}
+
+package(){
+ cd "qTsConverter"
+ make DESTDIR="$pkgdir" install
+}