summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2013-12-25 20:43:49 -0500
committerSlashbunny2013-12-25 20:43:49 -0500
commit3c98d68fbe505b73899f82d1397aa7f09bc93d97 (patch)
treec9e95339d81e784a55468f1a8c5c230c2b0a2e71
parent4f63d518c8440b3f2c8d3bcbd482ec8b276294b0 (diff)
downloadaur-3c98d68fbe505b73899f82d1397aa7f09bc93d97.tar.gz
Minor cleanup/modernization of PKGBUILD
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
2 files changed, 13 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 284901bf34a6..5bab112942a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,14 +3,13 @@ pkgbase = quake3-cpma
pkgver = 1.48
pkgrel = 1
url = http://eu.promode.ru/
- arch = i686
- arch = x86_64
+ arch = any
license = custom
depends = quake3
source = quake3-cpma.launcher
source = http://promode.ru/files/cpma148-nomaps.zip
- md5sums = ba3def87863a0199824902e271ae4968
- md5sums = 9d0d0277b956bc0ce0cac1f4e49fca9b
+ sha256sums = 73307f10927bef8cd29000303e1448383d1003727121fd1f7840d6db98ddca92
+ sha256sums = 1f0aafcaa48a16880ab4541aaa8b9d017c6c0b90c8fc0b4de871f976c05598d5
pkgname = quake3-cpma
diff --git a/PKGBUILD b/PKGBUILD
index c8761269e8dc..ae7f38c0cc34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,21 @@
pkgname=quake3-cpma
pkgver=1.48
pkgrel=1
-pkgdesc="Challenge ProMode Arena (CPMA) is a Quake3 modification which adds features aimed towards professional gamers and competitive enviroments. "
+pkgdesc="Challenge ProMode Arena (CPMA) is a Quake3 modification which adds features aimed towards professional gamers and competitive enviroments."
url="http://eu.promode.ru/"
license=('custom')
-arch=('i686' 'x86_64')
+arch=('any')
depends=('quake3')
-source=('quake3-cpma.launcher' \
-'http://promode.ru/files/cpma148-nomaps.zip')
-md5sums=('ba3def87863a0199824902e271ae4968'
- '9d0d0277b956bc0ce0cac1f4e49fca9b')
-
-build() {
- cd $srcdir
+source=('quake3-cpma.launcher' 'http://promode.ru/files/cpma148-nomaps.zip')
+sha256sums=('73307f10927bef8cd29000303e1448383d1003727121fd1f7840d6db98ddca92'
+ '1f0aafcaa48a16880ab4541aaa8b9d017c6c0b90c8fc0b4de871f976c05598d5')
+package() {
# Base CPMA Files
- install -d $pkgdir/opt/quake3/
- mv $srcdir/cpma $pkgdir/opt/quake3/
+ install -d ${pkgdir}/opt/quake3/
+ mv ${srcdir}/cpma ${pkgdir}/opt/quake3/
# Install Launcher
- install -D -m 755 $srcdir/quake3-cpma.launcher \
- $pkgdir/usr/bin/quake3-cpma
+ install -D -m 755 ${srcdir}/quake3-cpma.launcher \
+ ${pkgdir}/usr/bin/quake3-cpma
}