summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Sopp2018-09-18 22:07:19 +0200
committerKevin Sopp2018-09-18 22:07:19 +0200
commitee766196ed4581abb7e4d77f44c8dc415b26cce8 (patch)
treec9ac9b8ec3f958fc70adc56108a32826122d4235
downloadaur-quakewatch.tar.gz
Initial commit of version 1.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..625418f69ca1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = quakewatch
+ pkgdesc = Lists the latest earthquakes on the command-line
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/baraclese/quakewatch
+ arch = any
+ license = GPL3
+ depends = python
+ depends = python-requests
+ depends = python-tabulate
+ source = https://github.com/baraclese/quakewatch/archive/v1.0.tar.gz
+ sha256sums = ca1f56d9277a063bd0dd8f05e789dce858ffaf51afd31432fda68ac7ac02b2c3
+
+pkgname = quakewatch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92f5b934b7d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: baraclese at gmail dot com
+pkgname=quakewatch
+pkgver=1.0
+pkgrel=1
+pkgdesc="Lists the latest earthquakes on the command-line"
+url="https://github.com/baraclese/quakewatch"
+arch=('any')
+license=('GPL3')
+depends=(
+ python
+ python-requests
+ python-tabulate
+)
+source=("https://github.com/baraclese/quakewatch/archive/v${pkgver}.tar.gz")
+sha256sums=(ca1f56d9277a063bd0dd8f05e789dce858ffaf51afd31432fda68ac7ac02b2c3)
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 quakewatch "$pkgdir/usr/bin/quakewatch"
+}