summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2018-07-06 00:52:36 +0300
committerAdrian Perez de Castro2018-07-06 00:52:36 +0300
commit80c2691724cc4b99b715f485ab864eb7dfa5f42a (patch)
treec7fdab531a5d9f44e5df2df2fbcffd9bc9119713
parentd9e388088b128f0b0b559e5eb93042a76d4dd62c (diff)
downloadaur-quicktun.tar.gz
Update to version 2.2.5
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD15
-rw-r--r--build.patch14
4 files changed, 34 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e51653ce82a..940903e36fb2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = quicktun
pkgdesc = Simple and secure VPN software
- pkgver = 2.2.4
- pkgrel = 2
- url = http://wiki.ucis.nl/QuickTun
+ pkgver = 2.2.5
+ pkgrel = 1
+ url = http://wiki.qontrol.nl/QuickTun
arch = i686
arch = x86_64
arch = arm
license = custom
depends = libsodium
- source = http://oss.ucis.nl/quicktun/src/quicktun-2.2.4.tgz
- sha512sums = da60fc39d8e85d5b2c162633840b887be3fd58d9f2b3a99fe605fa13546e4f53878ce6246d835b7931e42193fb044330c539b29751cdb6f54d025efc52041487
+ source = http://oss.ucis.nl/quicktun/src/quicktun-2.2.5.tgz
+ source = build.patch
+ sha512sums = 1dacba92be6d8790cc6d0e0790f93dd0d047f06e366fbd21ef46478851c4d8c89412effd827e65bacab225d015e85938ddd6d617d8b84e80ac8adf33d94d8a94
+ sha512sums = 27854236255a20e45b8e3ec41e9f2b8fc3cac6eac1f010878c6df85197ad63238b9b6c506b8c0e7abe842760e377fc54722d31e86ead7a5ab19333f102981247
pkgname = quicktun
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b3e16bf99e00
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.tar
+/*.tgz
diff --git a/PKGBUILD b/PKGBUILD
index b940d20d9e21..619b83638104 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,25 @@
pkgname='quicktun'
pkgdesc='Simple and secure VPN software'
-pkgver='2.2.4'
-pkgrel='2'
+pkgver='2.2.5'
+pkgrel='1'
arch=('i686' 'x86_64' 'arm')
depends=('libsodium')
-url='http://wiki.ucis.nl/QuickTun'
+url='http://wiki.qontrol.nl/QuickTun'
license=('custom')
-source=("http://oss.ucis.nl/quicktun/src/${pkgname}-${pkgver}.tgz")
-sha512sums=('da60fc39d8e85d5b2c162633840b887be3fd58d9f2b3a99fe605fa13546e4f53878ce6246d835b7931e42193fb044330c539b29751cdb6f54d025efc52041487')
+source=("http://oss.ucis.nl/quicktun/src/${pkgname}-${pkgver}.tgz"
+ 'build.patch')
+sha512sums=('1dacba92be6d8790cc6d0e0790f93dd0d047f06e366fbd21ef46478851c4d8c89412effd827e65bacab225d015e85938ddd6d617d8b84e80ac8adf33d94d8a94'
+ '27854236255a20e45b8e3ec41e9f2b8fc3cac6eac1f010878c6df85197ad63238b9b6c506b8c0e7abe842760e377fc54722d31e86ead7a5ab19333f102981247')
prepare () {
cd "${pkgname}-${pkgver}"
sed -e '1,/\*\//p' -e d src/keypair.c > COPYING
+ patch -p0 < "${srcdir}/build.patch"
}
build() {
cd "${pkgname}-${pkgver}"
- CFLAGS='-Wno-pointer-to-int-cast' ./build.sh
+ ./build.sh
}
package () {
diff --git a/build.patch b/build.patch
new file mode 100644
index 000000000000..24ffc950a5fa
--- /dev/null
+++ b/build.patch
@@ -0,0 +1,14 @@
+--- build.sh.orig 2018-07-06 00:43:04.030029578 +0300
++++ build.sh 2018-07-06 00:43:29.203926254 +0300
+@@ -23,11 +23,6 @@
+ rm -rf out/ obj/ tmp/
+
+ mkdir -p out
+-if [ "$1" != "debian" ]; then
+- echo Creating source archive...
+- $tar --transform "s,^,quicktun-`cat version`/," -czf "out/quicktun-`cat version`.tgz" build.sh clean.sh debian src version --exclude "debian/data"
+-fi
+-
+ mkdir -p obj tmp tmp/include tmp/lib
+
+ export LIBRARY_PATH="/usr/local/lib/:${LIBRARY_PATH}"