summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2023-01-12 18:02:08 -0500
committeréclairevoyant2023-01-12 18:02:08 -0500
commit99e365f6b2f47206a6852226f5be1d1cea9ce917 (patch)
treedaf38cbc55899b641e469464f04aacde1b7bd4d2
parent4b0ef0803fdb2bf1ee077b73fda52944d14bee77 (diff)
downloadaur-quiterss.tar.gz
quiterss: fix patch file, add .gitignore
Signed-off-by: éclairevoyant <848000+eclairevoyant@users.noreply.github.com>
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD25
-rw-r--r--install-appdata.patch53
4 files changed, 42 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20bbb912eb58..d8bc6dc63c7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = quiterss
pkgdesc = Fast and light RSS/Atom feed reader written in Qt/С++
pkgver = 0.19.4
- pkgrel = 2
+ pkgrel = 3
url = https://quiterss.org/
arch = x86_64
license = GPL3
@@ -11,7 +11,7 @@ pkgbase = quiterss
depends = qt5-webkit
source = https://github.com/QuiteRSS/quiterss/archive/0.19.4/quiterss-0.19.4.tar.gz
source = install-appdata.patch
- sha256sums = d9dffa205a8ec4e7bf00d87183fd94d4a12f045fae04a6efd41d6557827233bc
- sha256sums = 81cc287b8fbd53016a125f210c193c58bcac093cc86ee226c5f4fd23b26188c9
+ b2sums = d1515a13b4b26a9bfae1760d25e1ab28b1ca797806dc49f2826631764755ad61f5ed887a1c17f6728f45b0fd33271f06157acb1a529a628e0a0f5acb436bee23
+ b2sums = 264544b9ecaa01be3afa6d6930aa1006e21c3b87de5b71e304961fc9b8ad5fbc895e7a911fb48bd4560260d2af9959ee6c80699d1ebf24d7e3ce182d1f50fe7e
pkgname = quiterss
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..31b7f2f8ff1d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!install-appdata.patch
diff --git a/PKGBUILD b/PKGBUILD
index 865dedd87607..81f3e4742c08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
-# Maintainer: Balló György <ballogyor+arch at gmail dot com>
+# Maintainer: éclairevoyant
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
# Contributor: willemw <willemw12@gmail.com>
# Contributor: ThecaTTony <thecattony at gmx dot com>
# Contributor: <giacomogiorgianni at gmail dot com>
pkgname=quiterss
pkgver=0.19.4
-pkgrel=2
+pkgrel=3
pkgdesc='Fast and light RSS/Atom feed reader written in Qt/С++'
arch=('x86_64')
url='https://quiterss.org/'
@@ -14,22 +15,22 @@ depends=('gst-plugins-good' 'qt5-multimedia' 'qt5-webkit')
makedepends=('qt5-tools')
source=("https://github.com/QuiteRSS/$pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz"
'install-appdata.patch')
-sha256sums=('d9dffa205a8ec4e7bf00d87183fd94d4a12f045fae04a6efd41d6557827233bc'
- '81cc287b8fbd53016a125f210c193c58bcac093cc86ee226c5f4fd23b26188c9')
+b2sums=('d1515a13b4b26a9bfae1760d25e1ab28b1ca797806dc49f2826631764755ad61f5ed887a1c17f6728f45b0fd33271f06157acb1a529a628e0a0f5acb436bee23'
+ '264544b9ecaa01be3afa6d6930aa1006e21c3b87de5b71e304961fc9b8ad5fbc895e7a911fb48bd4560260d2af9959ee6c80699d1ebf24d7e3ce182d1f50fe7e')
prepare() {
- cd $pkgname-$pkgver
- patch -Np1 -i ../install-appdata.patch
- sed -i '/INSTALLS +=/ s/ target1//' QuiteRSS.pro
+ cd $pkgname-$pkgver
+ patch -Np1 -i ../install-appdata.patch
+ sed -i '/INSTALLS +=/ s/ target1//' QuiteRSS.pro
}
build() {
- cd $pkgname-$pkgver
- qmake-qt5 CONFIG+=release PREFIX=/usr
- make
+ cd $pkgname-$pkgver
+ qmake-qt5 CONFIG+=release PREFIX=/usr
+ make
}
package() {
- cd $pkgname-$pkgver
- make INSTALL_ROOT="$pkgdir" install
+ cd $pkgname-$pkgver
+ make INSTALL_ROOT="$pkgdir" install
}
diff --git a/install-appdata.patch b/install-appdata.patch
index 3f784f7f0fb3..129144ffd2ef 100644
--- a/install-appdata.patch
+++ b/install-appdata.patch
@@ -1,32 +1,21 @@
-From ea8b4dce33fd5a74012d14d92bef43e26c6dda66 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Ball=C3=B3=20Gy=C3=B6rgy?= <ballogyor@gmail.com>
-Date: Sat, 17 Apr 2021 21:00:32 +0200
-Subject: [PATCH] Install appdata file
-
----
- QuiteRSS.pro | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/QuiteRSS.pro b/QuiteRSS.pro
-index d5088fdf..22dceac5 100644
---- a/QuiteRSS.pro
-+++ b/QuiteRSS.pro
-@@ -287,6 +287,9 @@ unix:!mac {
-
- desktop.files = quiterss.desktop
- desktop.path = $$quote($$PREFIX/share/applications)
-+
-+ appdata.files = quiterss.appdata.xml
-+ appdata.path = $$quote($$PREFIX/share/metainfo)
-
- target1.files = images/48x48/quiterss.png
- target1.path = $$quote($$PREFIX/share/pixmaps)
-@@ -314,7 +317,7 @@ unix:!mac {
- style.files = style
- style.path = $$quote($$DATA_DIR)
-
-- INSTALLS += target desktop target1
-+ INSTALLS += target desktop appdata target1
- INSTALLS += icon_16 icon_32 icon_48 icon_64 icon_128 icon_256
- INSTALLS += translations sound style
- }
+--- a/QuiteRSS.pro 2023-01-12 17:47:21.994842264 -0500
++++ b/QuiteRSS.pro 2023-01-12 17:49:04.825143301 -0500
+@@ -285,6 +285,9 @@
+ desktop.files = quiterss.desktop
+ desktop.path = $$quote($$PREFIX/share/applications)
+
++ appdata.files = quiterss.appdata.xml
++ appdata.path = $$quote($$PREFIX/share/metainfo)
++
+ target1.files = images/48x48/quiterss.png
+ target1.path = $$quote($$PREFIX/share/pixmaps)
+
+@@ -311,7 +314,7 @@
+ style.files = style
+ style.path = $$quote($$DATA_DIR)
+
+- INSTALLS += target desktop target1
++ INSTALLS += target desktop appdata target1
+ INSTALLS += icon_16 icon_32 icon_48 icon_64 icon_128 icon_256
+ INSTALLS += translations sound style
+ }