summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustforlxz2024-01-10 20:33:08 +0800
committerjustforlxz2024-01-10 20:33:08 +0800
commit9abf7fb942936ca52fbd4f7bafd828e636d1f094 (patch)
tree7095b9cfe94190e687af1654c664d7dae389019f
downloadaur-qwlroots.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36aec36ce3c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = qwlroots
+ pkgdesc = Qt and QML bindings for wlroots.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/vioken/qwlroots
+ arch = x86_64
+ arch = aarch64
+ license = Apache
+ license = GPL2
+ license = GPL3
+ license = LGPL3
+ makedepends = git
+ makedepends = wlroots
+ makedepends = ninja
+ makedepends = wayland-protocols
+ makedepends = wlr-protocols-git
+ source = https://github.com/vioken/qwlroots/archive/0.1.0/qwlroots-0.1.0.tar.gz
+ sha512sums = SKIP
+
+pkgname = qwlroots
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..648b961c61b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: justforlxz <justforlxz@gmail.com>
+
+pkgname=qwlroots
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='Qt and QML bindings for wlroots.'
+arch=('x86_64' 'aarch64')
+url="https://github.com/vioken/qwlroots"
+license=('Apache' 'GPL2' 'GPL3' 'LGPL3')
+depends=()
+makedepends=('git' 'wlroots' 'ninja' 'wayland-protocols' 'wlr-protocols-git')
+source=("https://github.com/vioken/qwlroots/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('SKIP')
+
+build() {
+ cd $pkgname-$pkgver
+ cmake -B . \
+ -G Ninja \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBEXEC=libexec
+ cmake --build .
+}
+
+package() {
+ cd $pkgname-$pkgver
+ DESTDIR="$pkgdir" ninja install
+}