summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2019-05-01 11:42:53 +0000
committerAntonio Rojas2019-05-01 11:42:53 +0000
commit5a00fea6530971dce27ce49f35b26813fd0f228e (patch)
treea8cb1c2a08611bac741458b82799fa93c44843b6
downloadaur-qwt5.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD40
-rw-r--r--qwtconfig-archlinux.pri86
3 files changed, 141 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b14c8b439f0f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = qwt5
+ pkgdesc = Qt Widgets for Technical Applications (version 5.X)
+ pkgver = 5.2.3
+ pkgrel = 5
+ url = http://qwt.sourceforge.net/
+ arch = x86_64
+ license = custom
+ depends = qt4
+ source = https://downloads.sourceforge.net/sourceforge/qwt/qwt-5.2.3.tar.bz2
+ source = qwtconfig-archlinux.pri
+ sha512sums = 60545712790699b145a54baba4c40802d9a58bf5f68f997faed5027db6773a801097be8675e00b2af1de568e36e2e498db0a0310ac4877fd9f2b52871409dd49
+ sha512sums = a019108fb6af33a465c419a3af21f82673112e5edc12624a390439a97c95edcf18f8ea08b4a5b1340b50be5d5315e41b6188105768d4689602f29d88274749a4
+
+pkgname = qwt5
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d46852b55fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Evgeniy Alekseev <arcanis at archlinux dot org>
+# Contributor: Eugen Zagorodniy <https://github.com/ezag>
+# Contributor: Ronald van Haren <ronald at archlinux dot org>
+# Contributor: Nick Østergaard <oe.nick at gmail dot com>
+
+pkgname=qwt5
+pkgver=5.2.3
+pkgrel=5
+pkgdesc="Qt Widgets for Technical Applications (version 5.X)"
+arch=('x86_64')
+url="http://qwt.sourceforge.net/"
+depends=('qt4')
+license=("custom")
+source=("https://downloads.sourceforge.net/sourceforge/qwt/qwt-${pkgver}.tar.bz2" \
+ "qwtconfig-archlinux.pri")
+sha512sums=('60545712790699b145a54baba4c40802d9a58bf5f68f997faed5027db6773a801097be8675e00b2af1de568e36e2e498db0a0310ac4877fd9f2b52871409dd49'
+ 'a019108fb6af33a465c419a3af21f82673112e5edc12624a390439a97c95edcf18f8ea08b4a5b1340b50be5d5315e41b6188105768d4689602f29d88274749a4')
+
+prepare() {
+ # copy our config file to the right place
+ install -Dm644 "qwtconfig-archlinux.pri" "qwt-${pkgver}/qwtconfig.pri"
+}
+
+build() {
+ cd "${srcdir}/qwt-${pkgver}"
+ qmake-qt4 qwt.pro
+ make
+}
+
+package() {
+ cd "${srcdir}/qwt-${pkgver}"
+
+ make INSTALL_ROOT="${pkgdir}" QTDIR=/usr install
+ # install licence
+ install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # remove docs
+ rm -r "${pkgdir}/usr/share/html"
+ rm -r "${pkgdir}/usr/share/man/"
+}
diff --git a/qwtconfig-archlinux.pri b/qwtconfig-archlinux.pri
new file mode 100644
index 000000000000..fcd31a5cb53e
--- /dev/null
+++ b/qwtconfig-archlinux.pri
@@ -0,0 +1,86 @@
+######################################################################
+# Install paths
+######################################################################
+
+unix {
+ INSTALLBASE = /usr
+}
+
+win32 {
+ INSTALLBASE = C:/Qwt
+}
+
+target.path = $$INSTALLBASE/lib
+headers.path = $$INSTALLBASE/include/qwt5
+doc.path = $$INSTALLBASE/share
+
+######################################################################
+# qmake internal options
+######################################################################
+
+CONFIG += qt # Also for Qtopia Core!
+CONFIG += warn_on
+CONFIG += thread
+
+######################################################################
+# release/debug mode
+# The designer plugin is always built in release mode.
+# If want to change this, you have to edit designer/designer.pro.
+######################################################################
+
+CONFIG += release # release/debug
+RELEASE_SUFFIX = 5
+
+######################################################################
+# Build the static/shared libraries.
+# If QwtDll is enabled, a shared library is built, otherwise
+# it will be a static library.
+######################################################################
+
+CONFIG += QwtDll
+
+######################################################################
+# QwtPlot enables all classes, that are needed to use the QwtPlot
+# widget.
+######################################################################
+
+CONFIG += QwtPlot
+
+######################################################################
+# QwtWidgets enables all classes, that are needed to use the all other
+# widgets (sliders, dials, ...), beside QwtPlot.
+######################################################################
+
+CONFIG += QwtWidgets
+
+######################################################################
+# If you want to display svg images on the plot canvas, enable the
+# line below. Note that Qwt needs the svg+xml, when enabling
+# QwtSVGItem.
+######################################################################
+
+CONFIG += QwtSVGItem
+
+######################################################################
+# If you have a commercial license you can use the MathML renderer
+# of the Qt solutions package to enable MathML support in Qwt.
+# So if you want this, copy qtmmlwidget.h + qtmmlwidget.cpp to
+# textengines/mathml and enable the line below.
+######################################################################
+
+#CONFIG += QwtMathML
+
+######################################################################
+# If you want to build the Qwt designer plugin,
+# enable the line below.
+# Otherwise you have to build it from the designer directory.
+######################################################################
+
+CONFIG += QwtDesigner
+
+######################################################################
+# If you want to auto build the examples, enable the line below
+# Otherwise you have to build them from the examples directory.
+######################################################################
+
+#CONFIG += QwtExamples