summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGergely Daróczi2015-06-21 21:28:58 -0700
committerGergely Daróczi2015-06-21 21:28:58 -0700
commit364d0613d656df5f0ec026ee579158e0a7dfc656 (patch)
tree7e9f823d1c14cc18e490745e0b1f24cfe706d620
downloadaur-r-deprecated-215.tar.gz
Initial import
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD61
-rw-r--r--r-215.desktop11
-rw-r--r--r-215.install12
-rw-r--r--r-215.pngbin0 -> 4261 bytes
5 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e25ec2b1bc1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = r-deprecated-215
+ pkgdesc = Language and environment for statistical computing and graphics - deprecated version (2.15.3)
+ pkgver = 215
+ pkgrel = 3
+ url = http://www.r-project.org/
+ install = r-215.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gcc-fortran
+ depends = blas
+ depends = lapack
+ depends = bzip2
+ depends = libpng
+ depends = libjpeg
+ depends = libtiff
+ depends = ncurses
+ depends = pcre
+ depends = readline
+ depends = zlib
+ depends = perl
+ depends = gcc-libs
+ depends = tk
+ depends = libxt
+ depends = libxmu
+ depends = pango
+ depends = xz
+ options = !makeflags
+ source = http://cran.rapporter.net/src/base/R-2/R-2.15.3.tar.gz
+ source = r-215.desktop
+ source = r-215.png
+ md5sums = b2f1a5d701f1f90679be0c60e1931a5c
+ md5sums = 74294ec8b4b06b6d43f6b48d4517de6e
+ md5sums = ba441e25f707d69566b84d90ca071ded
+
+pkgname = r-deprecated-215
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5d58a7ad275
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# $Id$
+# Contributor: Gergely Daróczi <gergely@snowl.net>
+# Based on [r-devel@AUR](http://aur.archlinux.org/packages.php?ID=52561) by Florian Breitwieser <florian.bw@gmail.com>
+
+pkgname=r-deprecated-215
+pkgver=215
+pkgrel=3
+pkgdesc="Language and environment for statistical computing and graphics - deprecated version (2.15.3)"
+arch=('i686' 'x86_64')
+license=('GPL')
+url=('http://www.r-project.org/')
+depends=('blas' 'lapack' 'bzip2' 'libpng' 'libjpeg' 'libtiff'
+ 'ncurses' 'pcre' 'readline' 'zlib' 'perl' 'gcc-libs'
+ 'tk' 'libxt' 'libxmu' 'pango' 'xz')
+makedepends=('gcc-fortran')
+options=('!makeflags')
+source=('http://cran.rapporter.net/src/base/R-2/R-2.15.3.tar.gz'
+ 'r-215.desktop'
+ 'r-215.png')
+install=r-215.install
+
+build() {
+ cd ${srcdir}/R-2.15.3
+ ./tools/rsync-recommended
+ ./configure --prefix=/opt/r-215 \
+ --enable-R-shlib \
+ --with-lapack \
+ --with-blas \
+ F77=gfortran \
+ LIBnn=lib
+ make
+}
+
+package() {
+ cd ${srcdir}/R-2.15.3
+ make -j1 DESTDIR=${pkgdir} install
+
+ # install some freedesktop.org compatibility
+ install -Dm644 ${srcdir}/r-215.desktop ${pkgdir}/usr/share/applications/r-215.desktop
+ install -Dm644 ${srcdir}/r-215.png ${pkgdir}/usr/share/pixmaps/r-215.png
+
+ # move the config directory to /etc and create symlinks
+ install -d ${pkgdir}/etc/R-215
+ cd ${pkgdir}/opt/r-215/lib/R/etc
+ for i in *; do
+ mv -f ${i} ${pkgdir}/etc/R-215
+ ln -s /etc/R-215/${i} ${i}
+ done
+
+ # links
+ install -d ${pkgdir}/usr/bin
+ ln -s /opt/r-215/bin/R ${pkgdir}/usr/bin/R-215
+ ln -s /opt/r-215/bin/Rscript ${pkgdir}/usr/bin/Rscript-215
+
+ # clear up stuffs
+ rm -rf ${srcdir}/R-2.15.35
+}
+
+md5sums=('b2f1a5d701f1f90679be0c60e1931a5c'
+ '74294ec8b4b06b6d43f6b48d4517de6e'
+ 'ba441e25f707d69566b84d90ca071ded')
diff --git a/r-215.desktop b/r-215.desktop
new file mode 100644
index 000000000000..1998b5703ada
--- /dev/null
+++ b/r-215.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=R-devel
+GenericName=environment for statistical computing - deprecated version (2.15.3)
+Comment=language and environment for statistical computing and graphics - deprecated version
+Exec=R-215
+Icon=/usr/share/pixmaps/r-215.png
+DocPath=/usr/lib/R-215/doc/html/index.html
+StartupNotify=true
+Terminal=true
+Type=Application
+Categories=Education;Science;Math;
diff --git a/r-215.install b/r-215.install
new file mode 100644
index 000000000000..d3289ab64233
--- /dev/null
+++ b/r-215.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
diff --git a/r-215.png b/r-215.png
new file mode 100644
index 000000000000..a9b699f9043f
--- /dev/null
+++ b/r-215.png
Binary files differ