summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel H. Neilson2021-05-28 11:42:48 -0400
committerDaniel H. Neilson2021-05-28 11:42:48 -0400
commit115da4cd94cfdd69880c1765606a9c22962ac219 (patch)
treef5c19400c61153cb0c63708caa08ffb3032bd526
downloadaur-r-ecb.tar.gz
Initial setup for CRAN installation of R package ecb.
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD24
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4da048791cfa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = r-ecb
+ pkgdesc = Provides an interface to the European Central Bank's Statistical Data Warehouse API, allowing for programmatic retrieval of a vast quantity of statistical data.
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://cran.r-project.org/web/packages/ecb/
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-curl
+ depends = r-rsdmx
+ depends = r-xml2
+ depends = r-httr
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-dplyr
+ optdepends = r-lubridate
+ optdepends = r-ggplot2
+ optdepends = r-testthat
+ optdepends = r-zoo
+ source = https://cran.r-project.org/src/contrib/ecb_0.4.0.tar.gz
+ sha512sums = 461ada1748ee779e10555bf429c08c936e36ccf42f5a686abb5bfbe5897c8c276571cbefa98de645160b9c201c2d91690ac78583b7740dea917f735e49848c89
+
+pkgname = r-ecb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83a0f7de2943
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: dhn <neilson+aur@sent.com>
+
+_pkgname=ecb
+pkgname=r-$_pkgname
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="Provides an interface to the European Central Bank's Statistical Data Warehouse API, allowing for programmatic retrieval of a vast quantity of statistical data."
+arch=('any')
+url="https://cran.r-project.org/web/packages/$_pkgname/"
+license=('GPL')
+depends=('r' 'r-curl' 'r-rsdmx' 'r-xml2' 'r-httr')
+makedepends=()
+optdepends=('r-knitr' 'r-rmarkdown' 'r-dplyr' 'r-lubridate' 'r-ggplot2' 'r-testthat' 'r-zoo')
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_$pkgver.tar.gz")
+sha512sums=('461ada1748ee779e10555bf429c08c936e36ccf42f5a686abb5bfbe5897c8c276571cbefa98de645160b9c201c2d91690ac78583b7740dea917f735e49848c89')
+
+build(){
+ R CMD INSTALL ${_pkgname}_$pkgver.tar.gz -l "$srcdir"
+}
+
+package() {
+ install -dm 755 "$pkgdir"/usr/lib/R/library
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}