summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-03-07 12:08:57 +0000
committerBioArchLinuxBot2024-03-07 12:08:57 +0000
commitad05b193e07a89023036d2dfa957a5d03a16cfa8 (patch)
tree5ee9d79f7c2a2b25c5d4702fdba2ac09668e1b24
parentba21dfd51b285bbca1612dd3fffd5e95f2b62849 (diff)
downloadaur-r-elliptic.tar.gz
[lilac] updated to 1.4.0-10
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD26
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7664dddec206..4d8e61fb3d0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = r-elliptic
pkgdesc = Weierstrass and Jacobi Elliptic Functions
pkgver = 1.4.0
- pkgrel = 5
+ pkgrel = 10
url = https://cran.r-project.org/package=elliptic
arch = any
- license = GPL
- depends = r
+ license = GPL-2.0-only
depends = pari
+ depends = r
optdepends = r-calibrator
optdepends = r-emulator
source = https://cran.r-project.org/src/contrib/elliptic_1.4-0.tar.gz
- sha256sums = b65729b1a1c7a84a5b1a59bfc893a2d35106853eaadcae31cda5c9ee3c500bb6
+ md5sums = eb083f4e62ee749a5eec9febb353a49f
+ b2sums = 600de80cbb973b99f13a5a378b72ac65c5598e43b33258c7cc8cbd0fd0ec06e439b258adf9c7ad45844213e93aaefd5064fbed4af840366fa3d64f184dd8c102
pkgname = r-elliptic
diff --git a/PKGBUILD b/PKGBUILD
index 4619a010f609..0ee346ef66bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,32 @@
-# system requirements: pari/gp
# Maintainer: sukanka <su975853527@gmail.com>
_pkgname=elliptic
_pkgver=1.4-0
pkgname=r-${_pkgname,,}
-pkgver=1.4.0
-pkgrel=5
-pkgdesc='Weierstrass and Jacobi Elliptic Functions'
-arch=('any')
-url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=10
+pkgdesc="Weierstrass and Jacobi Elliptic Functions"
+arch=(any)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-2.0-only')
depends=(
- r
pari
+ r
)
optdepends=(
r-calibrator
r-emulator
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('b65729b1a1c7a84a5b1a59bfc893a2d35106853eaadcae31cda5c9ee3c500bb6')
+md5sums=('eb083f4e62ee749a5eec9febb353a49f')
+b2sums=('600de80cbb973b99f13a5a378b72ac65c5598e43b33258c7cc8cbd0fd0ec06e439b258adf9c7ad45844213e93aaefd5064fbed4af840366fa3d64f184dd8c102')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: