summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 11:05:35 +0800
committerSukanka2022-06-06 11:05:35 +0800
commited7eeab4858e05b2fc388aa8dd2ae66adfb2c33a (patch)
tree9b1e24c2d2815f4a483c76f9440e026a84c92308
downloadaur-r-ggmcmc.tar.gz
add r-ggmcmc
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8eabc9aee866
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = r-ggmcmc
+ pkgdesc = Tools for Analyzing MCMC Simulations from Bayesian Inference
+ pkgver = 1.5.1.1
+ pkgrel = 4
+ url = https://cran.r-project.org/package=ggmcmc
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-dplyr
+ depends = r-ggally
+ depends = r-ggplot2
+ depends = r-tidyr
+ optdepends = r-cairo
+ optdepends = r-coda
+ optdepends = r-extrafont
+ optdepends = r-ggthemes
+ optdepends = r-gridextra
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ source = https://cran.r-project.org/src/contrib/ggmcmc_1.5.1.1.tar.gz
+ sha256sums = 41d883fe5341c4aa3f5653f10178cc12b164bbae702a827433105518b150def8
+
+pkgname = r-ggmcmc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2338194a2d71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=ggmcmc
+_pkgver=1.5.1.1
+pkgname=r-${_pkgname,,}
+pkgver=1.5.1.1
+pkgrel=4
+pkgdesc='Tools for Analyzing MCMC Simulations from Bayesian Inference'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-dplyr
+ r-ggally
+ r-ggplot2
+ r-tidyr
+)
+optdepends=(
+ r-cairo
+ r-coda
+ r-extrafont
+ r-ggthemes
+ r-gridextra
+ r-knitr
+ r-rmarkdown
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('41d883fe5341c4aa3f5653f10178cc12b164bbae702a827433105518b150def8')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: