summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-05-02 18:40:25 +0000
committerBioArchLinuxBot2024-05-02 18:40:25 +0000
commitc6cd8fd804e5b82abfd142b001fe605f369e8419 (patch)
treea0c14c91c4442504c493c184017c61c7b7725c6d
parentd592bd88404ea08182dfd3dc228cd9ea97f5a1b5 (diff)
downloadaur-r-go.db.tar.gz
[lilac] updated to 3.19.1-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4319b86d0752..88ecdb038ea8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = r-go.db
pkgdesc = A set of annotation maps describing the entire Gene Ontology
- pkgver = 3.18.0
+ pkgver = 3.19.1
pkgrel = 1
url = https://bioconductor.org/packages/GO.db
arch = any
- license = Artistic2.0
- depends = r
+ license = Artistic-2.0
depends = r-annotationdbi
optdepends = r-dbi
- source = https://bioconductor.org/packages/release/data/annotation/src/contrib/GO.db_3.18.0.tar.gz
- sha256sums = f580341e7fd19efa3e5789b993dd8ef0cf813a45c49a647a173c6f49c451d87e
+ source = https://bioconductor.org/packages/release/data/annotation/src/contrib/GO.db_3.19.1.tar.gz
+ md5sums = f2488feb5d271a911e796a94b7f80495
+ b2sums = 9ed727e78457ac8afc5953d5894be97328f57ed353953a6270c31e36188d8373e2044baf2a5e5bb90323464818600958e6bde7ad439ed9fae031b508e432a54b
pkgname = r-go.db
diff --git a/PKGBUILD b/PKGBUILD
index 96ebf16790e4..96e02cbf0a2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,30 @@
# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=GO.db
-_pkgver=3.18.0
+_pkgver=3.19.1
pkgname=r-${_pkgname,,}
-pkgver=3.18.0
+pkgver=${_pkgver//-/.}
pkgrel=1
-pkgdesc='A set of annotation maps describing the entire Gene Ontology'
-arch=('any')
-url="https://bioconductor.org/packages/${_pkgname}"
-license=('Artistic2.0')
+pkgdesc="A set of annotation maps describing the entire Gene Ontology"
+arch=(any)
+url="https://bioconductor.org/packages/$_pkgname"
+license=('Artistic-2.0')
depends=(
- r
r-annotationdbi
)
optdepends=(
r-dbi
)
source=("https://bioconductor.org/packages/release/data/annotation/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('f580341e7fd19efa3e5789b993dd8ef0cf813a45c49a647a173c6f49c451d87e')
+md5sums=('f2488feb5d271a911e796a94b7f80495')
+b2sums=('9ed727e78457ac8afc5953d5894be97328f57ed353953a6270c31e36188d8373e2044baf2a5e5bb90323464818600958e6bde7ad439ed9fae031b508e432a54b')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: