summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2022-02-13 19:06:04 +0100
committerHyacinthe Cartiaux2022-02-13 19:06:04 +0100
commit7caedf7a216ebd62a078d49469968758c8e92471 (patch)
tree1e9ff483dd6a88d96bd74a8f6847cb0f15e3c9d3
parentd7733a63653928ac708f50cc6e2f775c2bf54c39 (diff)
downloadaur-7caedf7a216ebd62a078d49469968758c8e92471.tar.gz
Import from github - https://github.com/dvdesolve/ArchRPkgs/blob/master/packages/r-jsonlite/PKGBUILD
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0678309a7a67..6fbd943fe1e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = r-jsonlite
pkgdesc = A Robust, High Performance JSON Parser and Generator for R
- pkgver = 1.7.2
+ pkgver = 1.7.3
pkgrel = 1
url = https://cran.r-project.org/package=jsonlite
arch = i686
@@ -9,13 +9,13 @@ pkgbase = r-jsonlite
depends = r
optdepends = r-httr
optdepends = r-curl
- optdepends = r-plyr
+ optdepends = r-vctrs
optdepends = r-testthat
optdepends = r-knitr
optdepends = r-rmarkdown
optdepends = r-r.rsp
optdepends = r-sf
- source = https://cran.r-project.org/src/contrib/jsonlite_1.7.2.tar.gz
- sha256sums = 06354b50435942f67ba264f79831e577809ef89e5f9a5a2201985396fe651fd2
+ source = https://cran.r-project.org/src/contrib/jsonlite_1.7.3.tar.gz
+ sha256sums = 720a0b5e36a5eb71677231442bba2267d077137cfa9e0700585acbee62eac558
pkgname = r-jsonlite
diff --git a/PKGBUILD b/PKGBUILD
index fe576b09d30e..c006e1254ec5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Kibouo <csonka.mihaly@hotmail.com>
# Contributor: Ward Segers <w@rdsegers.be>
# Contributor: Alex Branham <branham@utexas.edu>
_cranname=jsonlite
-_cranver=1.7.2
+_cranver=1.7.3
pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
@@ -13,9 +13,9 @@ arch=(i686 x86_64)
url="https://cran.r-project.org/package=${_cranname}"
license=(MIT)
depends=(r)
-optdepends=(r-httr r-curl r-plyr r-testthat r-knitr r-rmarkdown r-r.rsp r-sf)
+optdepends=(r-httr r-curl r-vctrs r-testthat r-knitr r-rmarkdown r-r.rsp r-sf)
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha256sums=('06354b50435942f67ba264f79831e577809ef89e5f9a5a2201985396fe651fd2')
+sha256sums=('720a0b5e36a5eb71677231442bba2267d077137cfa9e0700585acbee62eac558')
build() {
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"