summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Wagner2016-10-25 23:07:29 +0200
committerFlorian Wagner2016-10-25 23:07:29 +0200
commit21bcfa11926b1bdb54efc464ac08cf4217a9b9cf (patch)
tree8016bcd019b53030345c591505f6b6adb245d249
downloadaur-21bcfa11926b1bdb54efc464ac08cf4217a9b9cf.tar.gz
Initial version (1.6.0).
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2652c1007d01
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = r-cran-lubridate
+ pkgdesc = Functions to work with date-times and time-spans
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = http://cran.r-project.org/web/packages/lubridate/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = r
+ depends = r-cran-stringr
+ source = http://cran.r-project.org/src/contrib/lubridate_1.6.0.tar.gz
+ md5sums = 10d6d0433f714096927eb032dfafe289
+
+pkgname = r-cran-lubridate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a865ecb28270
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: wagnerflo <florian@wagner-flo.net>
+_cranname=lubridate
+_cranver=1.6.0
+pkgname=r-cran-$_cranname
+pkgver=${_cranver}
+pkgrel=1
+pkgdesc="Functions to work with date-times and time-spans"
+url="http://cran.r-project.org/web/packages/${_cranname}/index.html"
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('r' 'r-cran-stringr')
+source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('10d6d0433f714096927eb032dfafe289')
+
+package() {
+ mkdir -p ${pkgdir}/usr/lib/R/library
+ cd ${srcdir}
+ R CMD INSTALL ${_cranname} -l ${pkgdir}/usr/lib/R/library
+}