summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrobot Viktor2019-09-30 18:05:22 +0300
committerDrobot Viktor2019-09-30 18:05:22 +0300
commite6da4663d3b9135b997239bf05cd9774d04a17f7 (patch)
tree93f1c432ce9bbcea3bdd91874dc6775460bcc9c2
parente57aeecec0825176cb99fe36faabc440b87b1936 (diff)
downloadaur-e6da4663d3b9135b997239bf05cd9774d04a17f7.tar.gz
Fixed PKGBUILD
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
2 files changed, 22 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98a3702bd606..3089caf2cf39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = r-lubridate
- pkgdesc = Functions to work with date-times and time-spans
+ pkgdesc = Make Dealing with Dates a Little Easier
pkgver = 1.7.4
- pkgrel = 5
+ pkgrel = 6
url = http://cran.r-project.org/web/packages/lubridate/index.html
arch = i686
arch = x86_64
license = GPL2
+ makedepends = gcc
depends = r
depends = r-stringr
depends = r-rcpp
- provides = r-lubridate
- conflicts = r-lubridate
+ optdepends = r-testthat
+ optdepends = r-knitr
+ optdepends = r-covr
source = http://cran.r-project.org/src/contrib/lubridate_1.7.4.tar.gz
sha256sums = 510ca87bd91631c395655ee5029b291e948b33df09e56f6be5839f43e3104891
diff --git a/PKGBUILD b/PKGBUILD
index e37a9e87275e..1ab841217588 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,31 @@
-# Maintainer: Clint Valentine <valentine.clint@gmail.com>
-# Contributer: wagnerflo <florian@wagner-flo.net>
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Clint Valentine <valentine.clint@gmail.com>
+# Contributor: wagnerflo <florian@wagner-flo.net>
_cranname=lubridate
_cranver=1.7.4
pkgname=r-$_cranname
pkgver=${_cranver}
-pkgrel=5
-pkgdesc="Functions to work with date-times and time-spans"
+pkgrel=6
+pkgdesc="Make Dealing with Dates a Little Easier"
url="http://cran.r-project.org/web/packages/${_cranname}/index.html"
arch=('i686' 'x86_64')
license=('GPL2')
depends=('r' 'r-stringr' 'r-rcpp')
-provides=('r-lubridate')
-conflicts=('r-lubridate')
+makedepends=('gcc')
+optdepends=('r-testthat' 'r-knitr' 'r-covr')
source=(http://cran.r-project.org/src/contrib/"${_cranname}"_"${_cranver}".tar.gz)
sha256sums=('510ca87bd91631c395655ee5029b291e948b33df09e56f6be5839f43e3104891')
+build(){
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l $srcdir
+}
+
package() {
- mkdir -p "${pkgdir}"/usr/lib/R/library
cd "${srcdir}"
- R CMD INSTALL "${_cranname}" -l "${pkgdir}"/usr/lib/R/library
+
+ install -dm0755 "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "$_cranname" "$pkgdir/usr/lib/R/library"
}