summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-04-15 18:20:29 +0000
committerBioArchLinuxBot2024-04-15 18:20:29 +0000
commit1c9a3a43f68cfaeed7e4cf458e9436b5919e01fb (patch)
tree3a798b330e58ea154e291544e5a9ccf5cc9ab7ac
parent8174278d6214108033c4c474d963922c87a87366 (diff)
downloadaur-r-nanotator.tar.gz
[lilac] updated to 1.18.0-2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD28
2 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e0b7f5ed1b8..a624eca2dd2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = r-nanotator
pkgdesc = Next generation structural variant annotation and classification
pkgver = 1.18.0
- pkgrel = 1
+ pkgrel = 2
url = https://bioconductor.org/packages/nanotatoR
arch = any
- license = custom
- depends = r
+ license = LicenseRef-nanotatoR
depends = r-annotationdbi
depends = r-curl
depends = r-dplyr
@@ -26,6 +25,7 @@ pkgbase = r-nanotator
optdepends = r-rmarkdown
optdepends = r-yaml
source = https://bioconductor.org/packages/release/bioc/src/contrib/nanotatoR_1.18.0.tar.gz
- sha256sums = eb8200b0f4818ad032af934179ba779b1b9869d7a2e42b44bad5ccb3c823d0da
+ md5sums = e808c68591d98effbfdba4dbac07ac91
+ b2sums = 337e99575b94adc4658f8fa14e8358460f591effd1f723dc22f3f22492afd3aa7cb4e04d3e9a875db9208bdb1ca146082808fca0fadc5a154475f4c0582f75dd
pkgname = r-nanotator
diff --git a/PKGBUILD b/PKGBUILD
index 18cb19ad1489..794c4de106bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,13 @@
_pkgname=nanotatoR
_pkgver=1.18.0
pkgname=r-${_pkgname,,}
-pkgver=1.18.0
-pkgrel=1
-pkgdesc='Next generation structural variant annotation and classification'
-arch=('any')
-url="https://bioconductor.org/packages/${_pkgname}"
-license=('custom')
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="Next generation structural variant annotation and classification"
+arch=(any)
+url="https://bioconductor.org/packages/$_pkgname"
+license=('LicenseRef-nanotatoR')
depends=(
- r
r-annotationdbi
r-curl
r-dplyr
@@ -34,15 +33,18 @@ optdepends=(
r-yaml
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('eb8200b0f4818ad032af934179ba779b1b9869d7a2e42b44bad5ccb3c823d0da')
+md5sums=('e808c68591d98effbfdba4dbac07ac91')
+b2sums=('337e99575b94adc4658f8fa14e8358460f591effd1f723dc22f3f22492afd3aa7cb4e04d3e9a875db9208bdb1ca146082808fca0fadc5a154475f4c0582f75dd')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
- install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
}
-# vim:set ts=2 sw=2 et: