summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-04-25 18:07:27 +0000
committerBioArchLinuxBot2024-04-25 18:07:27 +0000
commit2d2db51fc7147e8b0a46192b8f07a7494478fa39 (patch)
treea7b3a33e46576adfc40b8856d3ccaaf68428eadd
parent47848552033b807d5aad4046e84a8cd0067a6d93 (diff)
downloadaur-r-rappdirs.tar.gz
[lilac] updated to 0.3.3-13
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD25
-rw-r--r--fix-tests.patch26
3 files changed, 45 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca424405fd2c..559a688a83ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = r-rappdirs
pkgdesc = Application Directories: Determine Where to Save Data, Caches, and Logs
pkgver = 0.3.3
- pkgrel = 12
+ pkgrel = 13
url = https://cran.r-project.org/package=rappdirs
arch = x86_64
license = MIT
@@ -13,7 +13,10 @@ pkgbase = r-rappdirs
optdepends = r-testthat
optdepends = r-withr
source = https://cran.r-project.org/src/contrib/rappdirs_0.3.3.tar.gz
+ source = fix-tests.patch
md5sums = cafdd5478c4a6094a9f3d7335fb4f889
- sha256sums = 49959f65b45b0b189a2792d6c1339bef59674ecae92f8c2ed9f26ff9e488c184
+ md5sums = 86106366bdf6586bb505dcc53dcc1ba2
+ b2sums = 2dd360804783d56269f4f9c96cfe057ba431ee9d71e69227f2338feec06cbff555d1707e01a2830647a7d7421d7dbc56452b88b985971cf1feb5d21bc1452cea
+ b2sums = a8b98e83b9cafdf1117627c99c13ec5fb2b05176d8c031e07eb888230e23d3a280308d8012c0dbf0312b22f83eca522f249155dfef0d8dd4855b4a7512e6d3e5
pkgname = r-rappdirs
diff --git a/PKGBUILD b/PKGBUILD
index 84bb6f635e40..46c21f43d670 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@
_pkgname=rappdirs
_pkgver=0.3.3
pkgname=r-${_pkgname,,}
-pkgver=${_pkgver//[:-]/.}
-pkgrel=12
+pkgver=${_pkgver//-/.}
+pkgrel=13
pkgdesc="Application Directories: Determine Where to Save Data, Caches, and Logs"
arch=(x86_64)
-url="https://cran.r-project.org/package=${_pkgname}"
-license=(MIT)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('MIT')
depends=(
r
)
@@ -24,18 +24,21 @@ optdepends=(
r-testthat
r-withr
)
-source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-md5sums=('cafdd5478c4a6094a9f3d7335fb4f889')
-sha256sums=('49959f65b45b0b189a2792d6c1339bef59674ecae92f8c2ed9f26ff9e488c184')
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz"
+ "fix-tests.patch")
+md5sums=('cafdd5478c4a6094a9f3d7335fb4f889'
+ '86106366bdf6586bb505dcc53dcc1ba2')
+b2sums=('2dd360804783d56269f4f9c96cfe057ba431ee9d71e69227f2338feec06cbff555d1707e01a2830647a7d7421d7dbc56452b88b985971cf1feb5d21bc1452cea'
+ 'a8b98e83b9cafdf1117627c99c13ec5fb2b05176d8c031e07eb888230e23d3a280308d8012c0dbf0312b22f83eca522f249155dfef0d8dd4855b4a7512e6d3e5')
prepare() {
- # fix test snapshot that is incompatible with r-testthat>=3.0.2
- sed -i '5d' "$_pkgname/tests/testthat/_snaps/appdir.md"
+ # fix outdated snapshot tests
+ patch -Np1 -i fix-tests.patch
}
build() {
- mkdir -p build
- R CMD INSTALL "$_pkgname" -l build
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
check() {
diff --git a/fix-tests.patch b/fix-tests.patch
new file mode 100644
index 000000000000..1ef04bf759be
--- /dev/null
+++ b/fix-tests.patch
@@ -0,0 +1,26 @@
+diff --git a/rappdirs/tests/testthat/_snaps/appdir.md b/rappdirs/tests/testthat/_snaps/appdir.md
+index fee84b4..31bb6cf 100644
+--- a/rappdirs/tests/testthat/_snaps/appdir.md
++++ b/rappdirs/tests/testthat/_snaps/appdir.md
+@@ -2,7 +2,6 @@
+
+ Code
+ app <- app_dir("ggplot2", "hadley", os = "mac")
+- Code
+ app$cache()
+ Output
+ [1] "~/Library/Caches/ggplot2"
+diff --git a/rappdirs/tests/testthat/_snaps/utils.md b/rappdirs/tests/testthat/_snaps/utils.md
+index 1322202..608bcfd 100644
+--- a/rappdirs/tests/testthat/_snaps/utils.md
++++ b/rappdirs/tests/testthat/_snaps/utils.md
+@@ -2,7 +2,8 @@
+
+ Code
+ expect_equal(check_version("1", NULL), NULL)
+- Warning <simpleWarning>
++ Condition
++ Warning:
+ version is ignored when appname is null
+ Code
+ expect_equal(check_version("1", "R"), "1")