summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2024-10-01 19:42:32 +0300
committerPekka Ristola2024-10-01 19:42:32 +0300
commit675d3a553dea363778a0e99dd247e765b0bb5d20 (patch)
tree9083a5b69cc6333a3a9d5e761080ab974b26c38e
downloadaur-r-stampp.tar.gz
Version 1.6.3
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b8d011222a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = r-stampp
+ pkgdesc = Statistical Analysis of Mixed Ploidy Populations
+ pkgver = 1.6.3
+ pkgrel = 1
+ url = https://cran.r-project.org/package=StAMPP
+ arch = any
+ license = GPL-3.0-only
+ depends = r-adegenet
+ depends = r-doparallel
+ depends = r-foreach
+ depends = r-pegas
+ source = https://cran.r-project.org/src/contrib/StAMPP_1.6.3.tar.gz
+ md5sums = 55572ba048c52d49532485790d4644a3
+ b2sums = 019a1b1b8d68c17a281fc4b2970efae0c5cf33a5950d9de8c511d501a86bf67c7bd82cc54942b9684a586f604784accb9fad80eb6b4c515fe74a23722bbf3bbe
+
+pkgname = r-stampp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0dde892ff44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=StAMPP
+_pkgver=1.6.3
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Statistical Analysis of Mixed Ploidy Populations"
+arch=(any)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-3.0-only')
+depends=(
+ r-adegenet
+ r-doparallel
+ r-foreach
+ r-pegas
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('55572ba048c52d49532485790d4644a3')
+b2sums=('019a1b1b8d68c17a281fc4b2970efae0c5cf33a5950d9de8c511d501a86bf67c7bd82cc54942b9684a586f604784accb9fad80eb6b4c515fe74a23722bbf3bbe')
+
+build() {
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}