summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-02-12 18:03:25 +0000
committerBioArchLinuxBot2024-02-12 18:03:25 +0000
commit337b8b3427c447d36a30c4c6594f020f8ee04078 (patch)
treea746191683e963b9efaad85a1436ce105f9cb9dd
parent40d5849919592b5d54cd509e4a836a6c15f9ec78 (diff)
downloadaur-r-stroma4.tar.gz
[lilac] updated to 1.24.0-2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD26
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c732a3b4f5a..3390f331ebb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = r-stroma4
pkgdesc = Assign Properties to TNBC Patients
pkgver = 1.24.0
- pkgrel = 1
+ pkgrel = 2
url = https://bioconductor.org/packages/STROMA4
arch = any
- license = GPL
- depends = r
+ license = GPL-3.0-only
depends = r-biobase
depends = r-biocparallel
depends = r-matrixstats
optdepends = r-breastcancermainz
- source = https://bioconductor.org/packages/release/bioc/src/contrib/STROMA4_1.24.0.tar.gz
- sha256sums = 2e19d4875c44509eac6aa6273789b12431522e2b84e29a10740e4dc6667f7ff4
+ source = https://bioconductor.org/packages/3.17/bioc/src/contrib/STROMA4_1.24.0.tar.gz
+ md5sums = c171d3ed28b97a1bfa044b8d360bf1f7
+ b2sums = bc979e8d2abf6d778b06572fdc8e6ada54dc6dfd183ae2886d3a4d741530ef48686c0d5d16e3c3850266e2874c5d1c9d576f21f271adaca138e7125c268720b4
pkgname = r-stroma4
diff --git a/PKGBUILD b/PKGBUILD
index e07fc856583c..495eb9f9f475 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,13 @@
_pkgname=STROMA4
_pkgver=1.24.0
pkgname=r-${_pkgname,,}
-pkgver=1.24.0
-pkgrel=1
-pkgdesc='Assign Properties to TNBC Patients'
-arch=('any')
-url="https://bioconductor.org/packages/${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="Assign Properties to TNBC Patients"
+arch=(any)
+url="https://bioconductor.org/packages/$_pkgname"
+license=('GPL-3.0-only')
depends=(
- r
r-biobase
r-biocparallel
r-matrixstats
@@ -18,15 +17,16 @@ depends=(
optdepends=(
r-breastcancermainz
)
-source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('2e19d4875c44509eac6aa6273789b12431522e2b84e29a10740e4dc6667f7ff4')
+source=("https://bioconductor.org/packages/3.17/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('c171d3ed28b97a1bfa044b8d360bf1f7')
+b2sums=('bc979e8d2abf6d778b06572fdc8e6ada54dc6dfd183ae2886d3a4d741530ef48686c0d5d16e3c3850266e2874c5d1c9d576f21f271adaca138e7125c268720b4')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: