summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-04-25 18:09:05 +0000
committerBioArchLinuxBot2024-04-25 18:09:05 +0000
commit87dcad14e74901986cd2ddf4d8fe7f75f669da06 (patch)
tree2cb8ceb0f9953bd698a46586a699c8359c1108d0
parent352eaec5f893f78353b6124c5db938c73ab81890 (diff)
downloadaur-r-tidyr.tar.gz
[lilac] updated to 1.3.1-3
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
-rw-r--r--fix-tests.patch78
3 files changed, 94 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c055a0b5caa..1d615c332ebb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = r-tidyr
pkgdesc = Tidy Messy Data
pkgver = 1.3.1
- pkgrel = 2
+ pkgrel = 3
url = https://cran.r-project.org/package=tidyr
arch = x86_64
license = MIT
@@ -27,7 +27,10 @@ pkgbase = r-tidyr
optdepends = r-rmarkdown
optdepends = r-testthat
source = https://cran.r-project.org/src/contrib/tidyr_1.3.1.tar.gz
+ source = fix-tests.patch
md5sums = 0491d9d3359af7baf8ad9003ce44aa1d
+ md5sums = c59cb36104f4ba2550cadc60b9af427e
b2sums = 43ec7fca79d137205847ae837a20f6ed2be8d4440cde29f6ff11cac0df35a1fbdb6d55d1365303819d25f5333819c9541a4e0a006e39e22cfa665c0f9d8fbf76
+ b2sums = 7567abe193a23f244e760e8eefc45af2438d3754fd4f628d2b5ddb9113a8f67bdd870acb8232a13504e97b807bd210195b4516d3e3c76e1a396496f8b1edf01c
pkgname = r-tidyr
diff --git a/PKGBUILD b/PKGBUILD
index 2f86f08a37fd..8199a103c3fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _pkgname=tidyr
_pkgver=1.3.1
pkgname=r-${_pkgname,,}
pkgver=${_pkgver//-/.}
-pkgrel=2
+pkgrel=3
pkgdesc="Tidy Messy Data"
arch=(x86_64)
url="https://cran.r-project.org/package=$_pkgname"
@@ -41,9 +41,17 @@ optdepends=(
r-rmarkdown
r-testthat
)
-source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-md5sums=('0491d9d3359af7baf8ad9003ce44aa1d')
-b2sums=('43ec7fca79d137205847ae837a20f6ed2be8d4440cde29f6ff11cac0df35a1fbdb6d55d1365303819d25f5333819c9541a4e0a006e39e22cfa665c0f9d8fbf76')
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz"
+ "fix-tests.patch")
+md5sums=('0491d9d3359af7baf8ad9003ce44aa1d'
+ 'c59cb36104f4ba2550cadc60b9af427e')
+b2sums=('43ec7fca79d137205847ae837a20f6ed2be8d4440cde29f6ff11cac0df35a1fbdb6d55d1365303819d25f5333819c9541a4e0a006e39e22cfa665c0f9d8fbf76'
+ '7567abe193a23f244e760e8eefc45af2438d3754fd4f628d2b5ddb9113a8f67bdd870acb8232a13504e97b807bd210195b4516d3e3c76e1a396496f8b1edf01c')
+
+prepare() {
+ # fix outdated snapshot tests
+ patch -Np1 -i fix-tests.patch
+}
build() {
mkdir build
diff --git a/fix-tests.patch b/fix-tests.patch
new file mode 100644
index 000000000000..ea64ccb8fbb6
--- /dev/null
+++ b/fix-tests.patch
@@ -0,0 +1,78 @@
+diff --git a/tidyr/tests/testthat/_snaps/drop-na.md b/tidyr/tests/testthat/_snaps/drop-na.md
+index abf9c67..3b5302b 100644
+--- a/tidyr/tests/testthat/_snaps/drop-na.md
++++ b/tidyr/tests/testthat/_snaps/drop-na.md
+@@ -5,7 +5,7 @@
+ Output
+ <error/vctrs_error_subscript_type>
+ Error in `drop_na()`:
+- ! Can't subset columns with `list()`.
++ ! Can't select columns with `list()`.
+ x `list()` must be numeric or character, not an empty list.
+
+ ---
+@@ -15,6 +15,6 @@
+ Output
+ <error/vctrs_error_subscript_oob>
+ Error in `drop_na()`:
+- ! Can't subset columns that don't exist.
++ ! Can't select columns that don't exist.
+ x Column `z` doesn't exist.
+
+diff --git a/tidyr/tests/testthat/_snaps/pivot-wide.md b/tidyr/tests/testthat/_snaps/pivot-wide.md
+index ebee7b2..222f39a 100644
+--- a/tidyr/tests/testthat/_snaps/pivot-wide.md
++++ b/tidyr/tests/testthat/_snaps/pivot-wide.md
+@@ -26,7 +26,7 @@
+ Output
+ <error/vctrs_error_subscript_oob>
+ Error in `pivot_wider()`:
+- ! Can't subset columns that don't exist.
++ ! Can't select columns that don't exist.
+ x Column `name` doesn't exist.
+
+ # `values_from` must be supplied if `value` isn't in `data` (#1240)
+@@ -36,7 +36,7 @@
+ Output
+ <error/vctrs_error_subscript_oob>
+ Error in `pivot_wider()`:
+- ! Can't subset columns that don't exist.
++ ! Can't select columns that don't exist.
+ x Column `value` doesn't exist.
+
+ # `names_from` must identify at least 1 column (#1240)
+@@ -165,7 +165,7 @@
+ Output
+ <error/vctrs_error_subscript_oob>
+ Error in `pivot_wider()`:
+- ! Can't subset columns that don't exist.
++ ! Can't select columns that don't exist.
+ x Column `foo` doesn't exist.
+
+ # named `id_cols` gives clear error (#1104)
+diff --git a/tidyr/tests/testthat/_snaps/separate-longer.md b/tidyr/tests/testthat/_snaps/separate-longer.md
+index a4723ad..53911b2 100644
+--- a/tidyr/tests/testthat/_snaps/separate-longer.md
++++ b/tidyr/tests/testthat/_snaps/separate-longer.md
+@@ -22,7 +22,7 @@
+ df %>% separate_longer_position(y, width = 1)
+ Condition
+ Error in `separate_longer_position()`:
+- ! Can't subset columns that don't exist.
++ ! Can't select columns that don't exist.
+ x Column `y` doesn't exist.
+ Code
+ df %>% separate_longer_position(x, width = 1.5)
+diff --git a/tidyr/tests/testthat/_snaps/separate-wider.md b/tidyr/tests/testthat/_snaps/separate-wider.md
+index 904dfad..bf9dcf5 100644
+--- a/tidyr/tests/testthat/_snaps/separate-wider.md
++++ b/tidyr/tests/testthat/_snaps/separate-wider.md
+@@ -184,7 +184,7 @@
+ df %>% separate_wider_regex(y, patterns = c(x = "-"))
+ Condition
+ Error in `separate_wider_regex()`:
+- ! Can't subset columns that don't exist.
++ ! Can't select columns that don't exist.
+ x Column `y` doesn't exist.
+ Code
+ df %>% separate_wider_regex(x, patterns = ".")