summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-22 15:39:30 +0800
committerzxp198210052024-03-22 15:39:30 +0800
commitcdf9aa478f3bc4e3130e841886e1b414ceba6d9c (patch)
tree8ab443362dfc040f819d2afe76caf5a253b765a3
parentbdcc56ed153b56867a57be78bbcfa9c57dbdff58 (diff)
downloadaur-r3playx-bin.tar.gz
fix errors
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
-rw-r--r--r3playx.sh5
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1b7509aff95..25f94e10b526 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = r3playx-bin
pkgdesc = A music player forked from YesPlayMusic。高颜值的第三方网易云播放器,支持 Windows / macOS / Linux
pkgver = 2.7.5
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/Sherlockouo/music
arch = aarch64
arch = x86_64
license = AGPL-3.0-only
depends = electron28
- depends = hicolor-icon-theme
provides = yesplaymusic
conflicts = r3playx
conflicts = r3play
conflicts = yesplaymusic
conflicts = my-yesplaymusic
source = r3playx.sh
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
source_aarch64 = r3playx-2.7.5-aarch64.deb::https://github.com/Sherlockouo/music/releases/download/2.7.5/R3PLAYX-2.7.5-linux-arm64.deb
sha256sums_aarch64 = 631444fcc800d112738d1abb8aacea2c94e0dfeaa39045055cd988fc144dbca2
source_x86_64 = r3playx-2.7.5-x86_64.deb::https://github.com/Sherlockouo/music/releases/download/2.7.5/R3PLAYX-2.7.5-linux-amd64.deb
diff --git a/PKGBUILD b/PKGBUILD
index 7dbc8ae5f5ca..d7c33bae5c03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=r3playx-bin
_pkgname=R3PLAYX
pkgver=2.7.5
_electronversion=28
-pkgrel=2
+pkgrel=3
pkgdesc="A music player forked from YesPlayMusic。高颜值的第三方网易云播放器,支持 Windows / macOS / Linux"
arch=(
'aarch64'
@@ -20,18 +20,18 @@ conflicts=(
provides=("yesplaymusic")
depends=(
"electron${_electronversion}"
- 'hicolor-icon-theme'
)
source=("${pkgname%-bin}.sh")
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${url}/releases/download/${pkgver}/${_pkgname}-${pkgver}-linux-arm64.deb")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${url}/releases/download/${pkgver}/${_pkgname}-${pkgver}-linux-amd64.deb")
-sha256sums=('50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+sha256sums=('dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
sha256sums_aarch64=('631444fcc800d112738d1abb8aacea2c94e0dfeaa39045055cd988fc144dbca2')
sha256sums_x86_64=('29412fd8023306a96bfa64c9766c580848b28578b70c266c75a55a7408d777c9')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*
sed -e "s|/opt/${_pkgname}/desktop|${pkgname%-bin}|g" \
diff --git a/r3playx.sh b/r3playx.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/r3playx.sh
+++ b/r3playx.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file