summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernd Amend2020-11-24 18:23:51 +0100
committerBernd Amend2020-11-24 18:23:51 +0100
commit7d7c437f0798ed0f837931c6ba3934ed5a31c662 (patch)
tree3914641d1a42f3130e5dcb09c0ccab1fde07c475
parent81296312e905bed9abc16aeb3ea3f1749c814dc4 (diff)
downloadaur-7d7c437f0798ed0f837931c6ba3934ed5a31c662.tar.gz
incorporate comments by aravance
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--dkms.conf2
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dcefb2c35320..cfc650304679 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = r8125-dkms
pkgdesc = Kernel module for RTL8125
pkgver = 9.004.01
- pkgrel = 4
+ pkgrel = 5
url = https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software
- arch = x86_64
+ arch = any
license = GPL2
depends = dkms
optdepends = linux-headers: Build the module for Arch kernel
optdepends = linux-lts-headers: Build the module for LTS Arch kernel
conflicts = r8125
- source = https://github.com/ibmibmibm/r8125/archive/master.tar.gz
+ source = https://github.com/aravance/r8125/archive/9.004.01.tar.gz
source = dkms.conf
- sha256sums = c25ec4ea817bd00108b023afbc19383ea177c042e6ee52c8c386c17615bb9b98
- sha256sums = 8a10787ee95ef4279408dc9711c23863926a8e6b9081161b47f56b78b0c54a9f
+ sha256sums = 00ed124510ccf7bcaa6972a2e3ce527c83aa9f6aa35a4d23abbb61b6916f60cb
+ sha256sums = ad4c67e0c74661d19b74872f98254184d4b04e32e4c57b338a84fbcefa4c721f
pkgname = r8125-dkms
diff --git a/PKGBUILD b/PKGBUILD
index d7de73c9fd0c..96b18a059d4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,23 +5,23 @@
_pkgname=r8125
pkgname=${_pkgname}-dkms
pkgver=9.004.01
-pkgrel=4
+pkgrel=5
url="https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software"
pkgdesc="Kernel module for RTL8125"
license=('GPL2')
-arch=('x86_64')
+arch=('any')
depends=('dkms')
conflicts=("${_pkgname}")
optdepends=('linux-headers: Build the module for Arch kernel'
'linux-lts-headers: Build the module for LTS Arch kernel')
-source=("https://github.com/ibmibmibm/r8125/archive/master.tar.gz" 'dkms.conf')
-sha256sums=('c25ec4ea817bd00108b023afbc19383ea177c042e6ee52c8c386c17615bb9b98'
- '8a10787ee95ef4279408dc9711c23863926a8e6b9081161b47f56b78b0c54a9f')
+source=("https://github.com/aravance/r8125/archive/9.004.01.tar.gz" 'dkms.conf')
+sha256sums=('00ed124510ccf7bcaa6972a2e3ce527c83aa9f6aa35a4d23abbb61b6916f60cb'
+ 'ad4c67e0c74661d19b74872f98254184d4b04e32e4c57b338a84fbcefa4c721f')
package() {
dir_name="${_pkgname}-${pkgver}"
install -d "${pkgdir}"/usr/src/${dir_name}/
- install -Dm644 dkms.conf "${_pkgname}-master"/src/* "${pkgdir}/usr/src/${dir_name}/"
+ install -Dm644 dkms.conf "${dir_name}"/src/* "${pkgdir}/usr/src/${dir_name}/"
sed -e "s/@_PKGNAME@/${_pkgname}/g" \
-e "s/@PKGVER@/${pkgver}/g" \
diff --git a/dkms.conf b/dkms.conf
index 74b22d83bb6f..d6b26d971882 100644
--- a/dkms.conf
+++ b/dkms.conf
@@ -3,5 +3,5 @@ PACKAGE_VERSION="@PKGVER@"
MAKE[0]="make -C $kernel_source_dir M=$dkms_tree/$PACKAGE_NAME/$PACKAGE_VERSION/build modules"
CLEAN="make -C $kernel_source_dir M=$dkms_tree/$PACKAGE_NAME/$PACKAGE_VERSION/build clean"
BUILT_MODULE_NAME[0]="@_PKGNAME@"
-DEST_MODULE_LOCATION[0]="/extramodules"
+DEST_MODULE_LOCATION[0]="/kernel/drivers/net/ethernet/realtek"
AUTOINSTALL="yes"