summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Sarawinski2017-08-13 02:52:49 +0200
committerTimo Sarawinski2017-08-13 02:52:49 +0200
commitc0afd5b7ac03658337201fae783e7d8365c83802 (patch)
treeb9bbfe1a069cd9e79089dec6b009c7d010e945a0
parent6efda81cb6e4362fb9049a60071e4c9f5c4497c8 (diff)
downloadaur-r8723bs-git.tar.gz
fixed build with newer kernels and added note in comments
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 17 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14f73c81e7ca..ce73e6668fc8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = r8723bs-git
- pkgver = 3dba47f12f8f3faadde8263a8ebbac673c6db87d
- pkgrel = 6
+ pkgver = .804.e12be86
+ pkgrel = 1
url = http://www.realtek.com.tw/
install = r8723bs-git.install
arch = any
license = GPL
provides = r8723bs
- source = r8723bs::git+https://github.com/hadess/rtl8723bs
+ source = r8723bs::git+https://github.com/muhviehstah/r8723bs
source = blacklist-8723bs.conf
source = osdep_includes.patch
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0a1ab4860e2b..b906858bfe5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,35 @@
# Maintainer: Timo Sarawinski <t.sarawinski@gmail.com>
+# Note: This driver has been merged into the 4.12+ Kernel Tree. This Package won't be updated anymore.
pkgname=r8723bs-git
_pkgname=r8723bs
-pkgver=3dba47f12f8f3faadde8263a8ebbac673c6db87d
-pkgrel=6
+pkgver=.804.e12be86
+pkgrel=1
url="http://www.realtek.com.tw/"
provides=('r8723bs')
arch=('any')
license=('GPL')
install=r8723bs-git.install
builddepends=('linux-headers')
-source=("${_pkgname}::git+https://github.com/hadess/rtl8723bs"
+source=("${_pkgname}::git+https://github.com/muhviehstah/r8723bs"
'blacklist-8723bs.conf' 'osdep_includes.patch')
sha256sums=('SKIP'
'52582494094670fd8c2aed16f4c8e2589889054810a0c5cf67bf2abe6473f7ea'
'27d123d1fcd05436b7426be8cf3b6664a3f6fc333f02e061fde77a19664262dd')
+pkgver() {
+ cd ${_pkgname}
+ printf "%s.%s.%s" \
+ "$(git tag -l|grep -P '.+\..+\.\d+'|sed -r 's|v?([0-9\.]+)(-.+)?|\1|g'|sort -V -r|head -n1)" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
build() {
-
cd "${srcdir}/${_pkgname}/"
patch -Np1 < "${srcdir}/osdep_includes.patch"
- make all $MAKEFLAGS
- make strip
+ CC=gcc-5 CXX=g++-5 make all $MAKEFLAGS
+ CC=gcc-5 CXX=g++-5 make strip
}
package() {