summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Webster2019-07-18 11:37:35 -0700
committerDonald Webster2019-07-18 11:37:35 -0700
commit7b07f062361abce4dfe7501451439dbd103b1b02 (patch)
treeb0a148aea995ee58c0cdd29f25d8a51f5ddeba9b
downloadaur-7b07f062361abce4dfe7501451439dbd103b1b02.tar.gz
Initial commit for radarr-aphrodite.
-rw-r--r--.SRCINFO32
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD45
-rw-r--r--radarr.service18
-rw-r--r--radarr.sysusers1
-rw-r--r--radarr.tmpfiles5
6 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b5eae001e4d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = radarr-aphrodite
+ pkgdesc = Movie download automation for usenet and torrents.
+ pkgver = 2.0.0.1404
+ pkgrel = 1
+ url = https://github.com/Radarr/Radarr
+ arch = any
+ license = GPL3
+ depends = mono
+ depends = libmediainfo
+ depends = sqlite
+ optdepends = sabnzbd: usenet downloader
+ optdepends = nzbget: usenet downloader
+ optdepends = transmission-cli: torrent downloader (CLI and daemon)
+ optdepends = transmission-gtk: torrent downloader (GTK+)
+ optdepends = transmission-qt: torrent downloader (Qt)
+ optdepends = deluge: torrent downloader
+ optdepends = rtorrent: torrent downloader
+ optdepends = jackett: torrent indexer proxy
+ optdepends = libgdiplus: provides a gdi+ compatible api
+ provides = radarr
+ conflicts = radarr
+ source = Radarr.aphrodite.2.0.0.1404.linux.tar.gz::https://ci.appveyor.com/api/buildjobs/bew3vttegs0mysvi/artifacts/_artifacts%2FRadarr.aphrodite.2.0.0.1404.linux.tar.gz
+ source = radarr.service
+ source = radarr.tmpfiles
+ source = radarr.sysusers
+ sha512sums = 1200f128aadd81d8e8621f55c28b21c98ec516f87e4fb18de4ac89814fee2b0d32cbd817a7d6af5fa51d9cbb3bf45654e51f67afb43be38b46e3d96ec8f83866
+ sha512sums = 4c064051c7592529a7ed41c4fdd6381b5e9ace938608f9e271aa4126194db456e85b7602d8e13718efcc4c40d66f82a338199cb6fd924177ad23154090e48da3
+ sha512sums = e0d55353f0bf89f826eb7eb9ee26c3e3f38bd46a8884135139536ae220c0c531d5df486bc3b50f580679f9607bb4b7bfb9f29998609dc966fbfb8e1809834650
+ sha512sums = c1ee3925eced182ea7fffa55a6dc2a4e099ccf18636fc237ef0a2fc9517a38cfc2a819ae5a7bc546b63e383506f9f47e89454a71e34106c579d7454d71b2299e
+
+pkgname = radarr-aphrodite
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6e570bc49abe
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.xz
+*.gz
+*.log
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15f3951465cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+
+# Maintainer: Donald Webster <fryfrog@gmail.com>
+# Helpful url: https://ci.appveyor.com/project/galli-leo/radarr-usby1/branch/aphrodite/artifacts
+# https://ci.appveyor.com/api/buildjobs/bew3vttegs0mysvi/artifacts/_artifacts%2FRadarr.aphrodite.2.0.0.1404.linux.tar.gz
+pkgname="radarr-aphrodite"
+pkgver="2.0.0.1404"
+_pkghash="bew3vttegs0mysvi"
+pkgrel=1
+pkgdesc="Movie download automation for usenet and torrents."
+arch=(any)
+url="https://github.com/Radarr/Radarr"
+license=('GPL3')
+depends=('mono' 'libmediainfo' 'sqlite')
+optdepends=('sabnzbd: usenet downloader'
+ 'nzbget: usenet downloader'
+ 'transmission-cli: torrent downloader (CLI and daemon)'
+ 'transmission-gtk: torrent downloader (GTK+)'
+ 'transmission-qt: torrent downloader (Qt)'
+ 'deluge: torrent downloader'
+ 'rtorrent: torrent downloader'
+ 'jackett: torrent indexer proxy'
+ 'libgdiplus: provides a gdi+ compatible api')
+
+provides=('radarr')
+conflicts=('radarr')
+
+source=("Radarr.aphrodite.${pkgver}.linux.tar.gz::https://ci.appveyor.com/api/buildjobs/${_pkghash}/artifacts/_artifacts%2FRadarr.aphrodite.${pkgver}.linux.tar.gz"
+ 'radarr.service'
+ 'radarr.tmpfiles'
+ 'radarr.sysusers')
+
+sha512sums=('1200f128aadd81d8e8621f55c28b21c98ec516f87e4fb18de4ac89814fee2b0d32cbd817a7d6af5fa51d9cbb3bf45654e51f67afb43be38b46e3d96ec8f83866'
+ '4c064051c7592529a7ed41c4fdd6381b5e9ace938608f9e271aa4126194db456e85b7602d8e13718efcc4c40d66f82a338199cb6fd924177ad23154090e48da3'
+ 'e0d55353f0bf89f826eb7eb9ee26c3e3f38bd46a8884135139536ae220c0c531d5df486bc3b50f580679f9607bb4b7bfb9f29998609dc966fbfb8e1809834650'
+ 'c1ee3925eced182ea7fffa55a6dc2a4e099ccf18636fc237ef0a2fc9517a38cfc2a819ae5a7bc546b63e383506f9f47e89454a71e34106c579d7454d71b2299e')
+
+package() {
+ install -d -m 755 "${pkgdir}/usr/lib/radarr"
+ cp -dpr --no-preserve=ownership "${srcdir}/Radarr/"* "${pkgdir}/usr/lib/radarr"
+ chmod -R a=,a+rX,u+w ${pkgdir}/usr/lib/radarr
+
+ install -D -m 644 "${srcdir}/radarr.service" "${pkgdir}/usr/lib/systemd/system/radarr.service"
+ install -D -m 644 "${srcdir}/radarr.sysusers" "${pkgdir}/usr/lib/sysusers.d/radarr.conf"
+ install -D -m 644 "${srcdir}/radarr.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/radarr.conf"
+}
diff --git a/radarr.service b/radarr.service
new file mode 100644
index 000000000000..cf93d79aaa86
--- /dev/null
+++ b/radarr.service
@@ -0,0 +1,18 @@
+[Unit]
+Description=Radarr Service
+Wants=network-online.target
+After=network-online.target
+
+[Service]
+User=radarr
+Group=radarr
+ExecStart=/usr/bin/mono --debug /usr/lib/radarr/Radarr.exe -nobrowser -data=/var/lib/radarr
+Type=simple
+TimeoutStopSec=20
+
+# Lets built in updater work well.
+Restart=on-failure
+KillMode=process
+
+[Install]
+WantedBy=multi-user.target
diff --git a/radarr.sysusers b/radarr.sysusers
new file mode 100644
index 000000000000..70d2a8677885
--- /dev/null
+++ b/radarr.sysusers
@@ -0,0 +1 @@
+u radarr - "Radarr daemon" /var/lib/radarr
diff --git a/radarr.tmpfiles b/radarr.tmpfiles
new file mode 100644
index 000000000000..0aacd9fb9a04
--- /dev/null
+++ b/radarr.tmpfiles
@@ -0,0 +1,5 @@
+# Override this file with a modified version in /etc/tmpfiles.d/
+d /var/lib/radarr 0755 radarr radarr
+Z /var/lib/radarr - radarr radarr
+Z /usr/lib/radarr - radarr radarr
+L /var/log/radarr - - - - /var/lib/radarr/logs/