summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolay Bryskin2024-04-05 15:21:51 +0300
committerNikolay Bryskin2024-04-05 15:21:51 +0300
commit943b1edd0bc3922c680606d10e61322a38518784 (patch)
treeec487e0b20478109fc31ec2b970344c0c43ddfd9
parent6a91f3a7ad5787714985296e0536580701af7310 (diff)
downloadaur-radicle-cli-git.tar.gz
Convert to radicle-cli-git
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD50
2 files changed, 43 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68ecb43644ef..c5bc4393be30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
-pkgbase = radicle-cli
+pkgbase = radicle-cli-git
pkgdesc = Radicle command line interface
- pkgver = 0.6.1
- pkgrel = 3
- url = https://app.radicle.xyz/seeds/seed.alt-clients.radicle.xyz/rad:git:hnrkmg77m8tfzj4gi4pa4mbhgysfgzwntjpao/tree
+ pkgver = 20240405.bc247dff
+ pkgrel = 1
+ url = https://app.radicle.xyz/nodes/seed.radicle.xyz/rad:z3gqcJUoA1n9HaHKufZs5FCSGazv5
arch = x86_64
- license = GPL3
+ arch = aarch64
+ license = MIT
+ license = Apache-2.0
makedepends = git
makedepends = cargo
depends = libusb
depends = gcc-libs
depends = openssl
- source = radicle-cli-0.6.1::git+https://github.com/radicle-dev/radicle-cli.git#commit=1e6ed9b
+ source = git+https://seed.radicle.xyz/z3gqcJUoA1n9HaHKufZs5FCSGazv5.git
sha512sums = SKIP
-pkgname = radicle-cli
- depends = libusb
- depends = gcc-libs
- depends = openssl
- depends = openssh
+pkgname = radicle-cli-git
diff --git a/PKGBUILD b/PKGBUILD
index b4e41c2e00d2..02c9f51870cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,44 @@
# Maintainer: Michael Bauer <michael@m-bauer.org>
-pkgname=radicle-cli
-pkgver=0.6.1
-pkgrel=3
+pkgname=radicle-cli-git
+pkgver=20240405.bc247dff
+pkgrel=1
pkgdesc="Radicle command line interface"
-arch=('x86_64')
-url="https://app.radicle.xyz/seeds/seed.alt-clients.radicle.xyz/rad:git:hnrkmg77m8tfzj4gi4pa4mbhgysfgzwntjpao/tree"
-license=('GPL3')
+arch=('x86_64' 'aarch64')
+_repoid=z3gqcJUoA1n9HaHKufZs5FCSGazv5
+url="https://app.radicle.xyz/nodes/seed.radicle.xyz/rad:$_repoid"
+license=('MIT' 'Apache-2.0')
depends=('libusb' 'gcc-libs' 'openssl')
makedepends=('git' 'cargo')
+source=("git+https://seed.radicle.xyz/$_repoid.git")
-_commit=1e6ed9b # tags/v0.6.1 - only available via github repo, missing on radicly.xyz :-(
-# _commit=4ae4174 # tags/0.6.0
+sha512sums=('SKIP')
-source=("$pkgname-$pkgver::git+https://github.com/radicle-dev/radicle-cli.git#commit=${_commit}")
-# TODO: Use radicle.xyz source instead of gituhub when release commit is available there
-# source=("$pkgname-$pkgver::git+https://seed.alt-clients.radicle.xyz/radicle-cli.git#commit=${_commit}")
+pkgver() {
+ cd "$srcdir/$_repoid"
+ git log -1 --format=%cd.%h --date=short|tr -d -
+}
-sha512sums=('SKIP')
+prepare() {
+ cd $_repoid
+ cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
+}
+
+build() {
+ cd $_repoid
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+check() {
+ cd $_repoid
+ cargo test --frozen --all-features
+}
package() {
- depends+=('openssh')
- cd "$pkgname-$pkgver"
- export RUSTUP_TOOLCHAIN=stable
- cargo install $pkgname --no-track --locked --root "$pkgdir/usr/" --path .
+ cd $_repoid
+ find target/release \
+ -maxdepth 1 \
+ -executable \
+ -type f \
+ -exec install -Dm0755 -t "$pkgdir/usr/bin/" {} +
}