summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2019-07-09 12:59:47 -0400
committerTed Alff2019-07-09 12:59:47 -0400
commit4c6ae221b2db7f64b8720991d68d8d977b456886 (patch)
treed61770691eaed8ed1dbb66323fdca261b27c50b6
parentf1ada34e3c9ef70a408044ff0bc4bef87c0e7ac4 (diff)
downloadaur-4c6ae221b2db7f64b8720991d68d8d977b456886.tar.gz
Version bump 0.2.6 + backport python3 port for rt2rtng script
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
-rw-r--r--rt2rtng_python3.patch72
3 files changed, 86 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f04bfe4811b4..3d7be3758e49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = radiotray-ng
pkgdesc = An Internet radio player for Linux
- pkgver = 0.2.5
+ pkgver = 0.2.6
pkgrel = 1
url = https://github.com/ebruck/radiotray-ng
arch = i686
@@ -19,10 +19,12 @@ pkgbase = radiotray-ng
depends = libxdg-basedir
depends = glibmm
depends = wxgtk3
- optdepends = python2-lxml: Convert radiotray bookmarks to radiotray-ng format
+ optdepends = python-lxml: Convert radiotray bookmarks to radiotray-ng format
options = !libtool
- source = radiotray-ng-0.2.5.tar.gz::https://github.com/ebruck/radiotray-ng/archive/v0.2.5.tar.gz
- sha256sums = 9b34f13f4290c98be9be555873d05507bbe7bcaa4ad0924655a4f38c8d55fe64
+ source = radiotray-ng-0.2.6.tar.gz::https://github.com/ebruck/radiotray-ng/archive/v0.2.6.tar.gz
+ source = rt2rtng_python3.patch
+ sha256sums = 05e1b9ac7342b276fff6395a38719264f9bc47b28aadd4938c5bbe3303c67553
+ sha256sums = 1965811963d5e02f08231f1c53a8a6db0bf146d8e745e8b7c76f3521f82142a3
pkgname = radiotray-ng
diff --git a/PKGBUILD b/PKGBUILD
index 25489de1d55c..1b6cc5775f80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: twa022 <twa022 at gmail dot com>
pkgname=radiotray-ng
-pkgver=0.2.5
+pkgver=0.2.6
pkgrel=1
pkgdesc="An Internet radio player for Linux"
arch=('i686' 'x86_64')
@@ -10,14 +10,17 @@ license=('GPL')
depends=('boost-libs' 'curl' 'gst-plugins-good' 'jsoncpp' 'libappindicator-gtk3'
'libbsd' 'libnotify' 'libxdg-basedir' 'glibmm' 'wxgtk3')
makedepends=('cmake' 'boost' 'lsb-release')
-optdepends=('python2-lxml: Convert radiotray bookmarks to radiotray-ng format')
+optdepends=('python-lxml: Convert radiotray bookmarks to radiotray-ng format')
options=('!libtool')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ebruck/radiotray-ng/archive/v${pkgver}.tar.gz")
-sha256sums=('9b34f13f4290c98be9be555873d05507bbe7bcaa4ad0924655a4f38c8d55fe64')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ebruck/radiotray-ng/archive/v${pkgver}.tar.gz"
+ 'rt2rtng_python3.patch')
+sha256sums=('05e1b9ac7342b276fff6395a38719264f9bc47b28aadd4938c5bbe3303c67553'
+ '1965811963d5e02f08231f1c53a8a6db0bf146d8e745e8b7c76f3521f82142a3')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- sed -i 's:-Werror::' CMakeLists.txt
+# sed -i 's:-Werror::' CMakeLists.txt
+ patch -Np1 -i ../rt2rtng_python3.patch
}
build() {
diff --git a/rt2rtng_python3.patch b/rt2rtng_python3.patch
new file mode 100644
index 000000000000..e3e6d04bf7c3
--- /dev/null
+++ b/rt2rtng_python3.patch
@@ -0,0 +1,72 @@
+From 49bddec6aacc49bee8d4d24dcf99657b98d318ae Mon Sep 17 00:00:00 2001
+From: Ed Bruck <ed.bruck1@gmail.com>
+Date: Mon, 8 Jul 2019 07:31:13 -0700
+Subject: [PATCH] Remove python2 dependency
+
+Fixes #118
+---
+ package/CMakeLists.txt | 4 ++--
+ src/radiotray-ng/extras/scripts/rt2rtng | 12 ++++++------
+ 2 files changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/package/CMakeLists.txt b/package/CMakeLists.txt
+index 7c48e86..273fe46 100644
+--- a/package/CMakeLists.txt
++++ b/package/CMakeLists.txt
+@@ -48,7 +48,7 @@ if (LSB_RELEASE_EXECUTABLE)
+ set(CPACK_DEBIAN_PACKAGE_ARCHITECTURE ${CPACK_SYSTEM_NAME})
+ set(CPACK_DEBIAN_PACKAGE_PRIORITY "optional")
+ set(CPACK_DEBIAN_PACKAGE_MAINTAINER "Edward G. Bruck <ed.bruck1@gmail.com>")
+- set(CPACK_DEBIAN_PACKAGE_DEPENDS "libc6, libbsd0, libcurl4, libjsoncpp1, libxdg-basedir1, libnotify4, python2.7, python-lxml, libglibmm-2.4-1v5, libboost-filesystem${BOOST_DEB_VERSION}, libboost-system${BOOST_DEB_VERSION}, libboost-log${BOOST_DEB_VERSION}, libboost-thread${BOOST_DEB_VERSION}, libboost-program-options${BOOST_DEB_VERSION}, libgstreamer1.0-0, libappindicator3-1, gstreamer1.0-plugins-good, gstreamer1.0-plugins-bad, gstreamer1.0-plugins-ugly, libwxgtk3.0-0v5")
++ set(CPACK_DEBIAN_PACKAGE_DEPENDS "libc6, libbsd0, libcurl4, libjsoncpp1, libxdg-basedir1, libnotify4, python3-lxml, libglibmm-2.4-1v5, libboost-filesystem${BOOST_DEB_VERSION}, libboost-system${BOOST_DEB_VERSION}, libboost-log${BOOST_DEB_VERSION}, libboost-thread${BOOST_DEB_VERSION}, libboost-program-options${BOOST_DEB_VERSION}, libgstreamer1.0-0, libappindicator3-1, gstreamer1.0-plugins-good, gstreamer1.0-plugins-bad, gstreamer1.0-plugins-ugly, libwxgtk3.0-0v5")
+ set(CPACK_DEBIAN_PACKAGE_CONTROL_EXTRA ${PROJECT_SOURCE_DIR}/package/postinst;${PROJECT_SOURCE_DIR}/package/postrm;${PROJECT_SOURCE_DIR}/package/conffiles)
+
+ # no libcurl4 on Debian Stretch
+@@ -73,7 +73,7 @@ if (LSB_RELEASE_EXECUTABLE)
+ if (CPACK_GENERATOR MATCHES "RPM")
+ set(CPACK_PACKAGE_DESCRIPTION_SUMMARY "Simple Internet Radio Player. Radiotray-NG runs in the system tray allowing you to select and play configured radio stations.")
+ set(CPACK_RPM_PACKAGE_URL "https://www.github.com/ebruck/radiotray-ng")
+- set(CPACK_RPM_PACKAGE_REQUIRES "glibc, libcurl, jsoncpp, boost, libxdg-basedir, libbsd, libappindicator-gtk3, libnotify, glibmm24, python2-lxml, gstreamer-plugins-base, gstreamer-plugins-good, gstreamer-plugins-bad-free, wxGTK3")
++ set(CPACK_RPM_PACKAGE_REQUIRES "glibc, libcurl, jsoncpp, boost, libxdg-basedir, libbsd, libappindicator-gtk3, libnotify, glibmm24, python3-lxml, gstreamer-plugins-base, gstreamer-plugins-good, gstreamer-plugins-bad-free, wxGTK3")
+ set(CPACK_RPM_PACKAGE_GROUP "Applications/Multimedia")
+ set(CPACK_RPM_PACKAGE_LICENSE "GPLv3")
+ set(CPACK_RPM_COMPRESSION_TYPE "xz")
+diff --git a/src/radiotray-ng/extras/scripts/rt2rtng b/src/radiotray-ng/extras/scripts/rt2rtng
+index 66f1c2e..2bf53ba 100755
+--- a/src/radiotray-ng/extras/scripts/rt2rtng
++++ b/src/radiotray-ng/extras/scripts/rt2rtng
+@@ -1,6 +1,6 @@
+-#!/usr/bin/env python2.7
++#!/usr/bin/env python3
+ #
+-# Copyright 2017 Edward G. Bruck <ed.bruck1@gmail.com>
++# Copyright 2017-2019 Edward G. Bruck <ed.bruck1@gmail.com>
+ #
+ # This file is part of Radiotray-NG.
+ #
+@@ -43,7 +43,7 @@ def walk_bookmarks(root, group_func, bookmark_func, group=""):
+
+ def group_callback(group_name):
+ if len(bookmarks):
+- if not bookmarks[0].has_key(group_name):
++ if group_name not in bookmarks[0]:
+ bookmarks.append({'group' : group_name, 'image' : '', 'stations' : [] })
+ else:
+ bookmarks.append({'group' : group_name, 'image' : '', 'stations' : [] })
+@@ -74,13 +74,13 @@ def prune_empty_groups():
+
+ if __name__ == "__main__":
+ if len(sys.argv) != 2:
+- print "usage: rt2rtng <path to radiotray bookmarks.xml>"
++ print("usage: rt2rtng <path to radiotray bookmarks.xml>")
+ exit(1)
+
+ if os.path.exists(sys.argv[1]):
+ root = etree.parse(sys.argv[1]).getroot()
+ walk_bookmarks(root, group_callback, bookmark_callback)
+ prune_empty_groups()
+- print json.dumps(bookmarks, indent=4)
++ print(json.dumps(bookmarks, indent=4))
+ else:
+- print sys.argv[1], "not found!"
++ print(sys.argv[1], "not found!")