summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2017-09-21 21:18:51 -0400
committerTed Alff2017-09-21 21:18:51 -0400
commitb82525150e01409337e3ab4a614981b242c45425 (patch)
treebb66f14af5fa8fe11d689cc813d90271a8bf782b
parentae5330cedb97c978fb20fe22fa5bd61980844988 (diff)
downloadaur-b82525150e01409337e3ab4a614981b242c45425.tar.gz
Some fixes for boost>=1.65. Don't build tests regardless if GMock is installed -- build fails.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--remove_GMock_check.patch24
3 files changed, 41 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34695d01fc63..3036658d6319 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Sep 2 21:06:31 UTC 2017
+# Fri Sep 22 01:18:44 UTC 2017
pkgbase = radiotray-ng
pkgdesc = An Internet radio player for Linux
pkgver = 0.1.7
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ebruck/radiotray-ng
arch = i686
arch = x86_64
@@ -23,7 +23,9 @@ pkgbase = radiotray-ng
optdepends = python2-lxml: Convert radiotray bookmarks to radiotray-ng format
options = !libtool
source = radiotray-ng.tar.gz::https://github.com/ebruck/radiotray-ng/archive/v0.1.7.tar.gz
+ source = remove_GMock_check.patch
sha256sums = d7fe4c9a61455b5feea05766f79ead37a6ba70e77b15908303708c4a6c37b844
+ sha256sums = 0859f5e90a03b3fd5a72f763c08900b45593f6ea0bd4b2aee4baec054d64c5a5
pkgname = radiotray-ng
diff --git a/PKGBUILD b/PKGBUILD
index f946ad151ccf..5e2ecf59d091 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=radiotray-ng
pkgver=0.1.7
-pkgrel=1
+pkgrel=2
pkgdesc="An Internet radio player for Linux"
arch=('i686' 'x86_64')
url="https://github.com/ebruck/radiotray-ng"
@@ -12,8 +12,18 @@ depends=('boost-libs' 'curl' 'gstreamer' 'jsoncpp' 'libappindicator-gtk3'
makedepends=('cmake' 'boost' 'lsb-release')
optdepends=('python2-lxml: Convert radiotray bookmarks to radiotray-ng format')
options=('!libtool')
-source=("${pkgname}.tar.gz::https://github.com/ebruck/radiotray-ng/archive/v${pkgver}.tar.gz")
-sha256sums=('d7fe4c9a61455b5feea05766f79ead37a6ba70e77b15908303708c4a6c37b844')
+source=("${pkgname}.tar.gz::https://github.com/ebruck/radiotray-ng/archive/v${pkgver}.tar.gz"
+ 'remove_GMock_check.patch')
+sha256sums=('d7fe4c9a61455b5feea05766f79ead37a6ba70e77b15908303708c4a6c37b844'
+ '0859f5e90a03b3fd5a72f763c08900b45593f6ea0bd4b2aee4baec054d64c5a5')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ # Build fails when GMock is found, so don't check for it, don't compile tests
+ patch -uNp2 -r- -i ../remove_GMock_check.patch
+ # Fix for boost >= 1.65
+ sed -i 's:find_package(Boost REQUIRED filesystem system log:& thread:' CMakeLists.txt
+}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/remove_GMock_check.patch b/remove_GMock_check.patch
new file mode 100644
index 000000000000..b49799e6f1a0
--- /dev/null
+++ b/remove_GMock_check.patch
@@ -0,0 +1,24 @@
+diff -Naur ./radiotray-ng-0.1.7.orig/CMakeLists.txt ./radiotray-ng-0.1.7/CMakeLists.txt
+--- ./radiotray-ng-0.1.7.orig/CMakeLists.txt 2017-09-21 21:13:04.449893764 -0400
++++ ./radiotray-ng-0.1.7/CMakeLists.txt 2017-09-21 21:12:46.776560740 -0400
+@@ -37,7 +37,6 @@
+ find_package(CURL REQUIRED)
+ find_package(PkgConfig REQUIRED)
+ find_package(Boost REQUIRED filesystem system log)
+-find_package(GMock)
+
+ pkg_search_module(JSONCPP REQUIRED jsoncpp)
+ pkg_search_module(GSTREAMER REQUIRED gstreamer-1.0)
+@@ -80,12 +79,6 @@
+ set(APPINDICATOR_FOUND false)
+ endif()
+
+-# gmock available?
+-if (GMOCK_FOUND)
+- enable_testing()
+- add_subdirectory(tests)
+-endif()
+-
+ add_subdirectory(src/radiotray-ng)
+ add_subdirectory(src/radiotray-ng/config)
+ add_subdirectory(src/radiotray-ng/playlist)