summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAthemis2018-07-10 15:15:49 +0200
committerAthemis2018-07-10 15:15:49 +0200
commite7bf824e2e2e24c41e1504131cd4e10f8ecae769 (patch)
treeafbf96272d7fa65ec6d39bfbcb72558187cf69a0
parentb89089cf8c62824cab48437ab611499a6430cad0 (diff)
downloadaur-e7bf824e2e2e24c41e1504131cd4e10f8ecae769.tar.gz
use inchi provided as AUR package
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 9 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 834e2a858225..7cb483d46e4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Jun 6 12:26:09 UTC 2018
+# Tue Jul 10 13:15:30 UTC 2018
pkgbase = rdkit-python2
pkgdesc = RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python.
pkgver = 2018_03_2
- pkgrel = 1
+ pkgrel = 2
url = http://rdkit.org/
arch = i686
arch = x86_64
@@ -19,13 +19,12 @@ pkgbase = rdkit-python2
depends = sqlite3
depends = python2-cairocffi
depends = python2-pillow
+ depends = inchi
provides = rdkit
conflicts = rdkit
conflicts = rdkit-git
source = https://github.com/rdkit/rdkit/archive/Release_2018_03_2.tar.gz
- source = http://www.inchi-trust.org/download/105/INCHI-1-SRC.zip
sha256sums = 29eeba93e723f0f9d61e31cf0f89ec18ba942a7f9e416dbc1a92122fce08cbed
- sha256sums = 4ac311ca3a16fa75d695ec4fc711e74045c6d6c882dea0dd1055961fba643720
pkgname = rdkit-python2
diff --git a/PKGBUILD b/PKGBUILD
index 62d2786aedd0..4ad46df0f7c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,20 @@
pkgname=rdkit-python2
_pkgname=RDKit
pkgver=2018_03_2
-pkgrel=1
+pkgrel=2
pkgdesc="RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python."
arch=("i686" "x86_64" "armv7h")
url="http://rdkit.org/"
license=('New BSD License')
-depends=( 'bison' 'boost' 'boost-libs' 'cmake' 'flex' 'python2' 'python2-numpy' 'sqlite3' 'python2-cairocffi' 'python2-pillow')
-source=("https://github.com/rdkit/rdkit/archive/Release_${pkgver}.tar.gz" "http://www.inchi-trust.org/download/105/INCHI-1-SRC.zip")
-sha256sums=('29eeba93e723f0f9d61e31cf0f89ec18ba942a7f9e416dbc1a92122fce08cbed'
- '4ac311ca3a16fa75d695ec4fc711e74045c6d6c882dea0dd1055961fba643720')
+depends=( 'bison' 'boost' 'boost-libs' 'cmake' 'flex' 'python2' 'python2-numpy' 'sqlite3' 'python2-cairocffi' 'python2-pillow' 'inchi')
+source=("https://github.com/rdkit/rdkit/archive/Release_${pkgver}.tar.gz")
+sha256sums=('29eeba93e723f0f9d61e31cf0f89ec18ba942a7f9e416dbc1a92122fce08cbed')
provides=('rdkit')
conflicts=('rdkit' 'rdkit-git')
build() {
- cd ${srcdir}
- mkdir build
- mkdir -p rdkit-Release_${pkgver}/External/INCHI-API/src
- cp -a INCHI-1-SRC/* rdkit-Release_${pkgver}/External/INCHI-API/src
- cd build
- cmake ../rdkit-Release_${pkgver} \
+ cd ${srcdir}/rdkit-Release_${pkgver}
+ cmake . \
-DCMAKE_BUILD_TYPE=Release \
-DRDK_INSTALL_INTREE=0 \
-DCMAKE_INSTALL_PREFIX=/usr \