summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabrice DIDIERJEAN2018-09-07 11:44:01 +0200
committerFabrice DIDIERJEAN2018-09-07 11:44:01 +0200
commit95ebff4510dc91273fe9495c64274c991265e503 (patch)
treee08bfa6290322775727d7b6018763ee2af61316b
downloadaur-reactotron-v1.tar.gz
create version 1 of reactotron
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD40
-rw-r--r--reactotron-v1.desktop9
-rw-r--r--reactotron-v1.pngbin0 -> 2546 bytes
4 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b37064d8a12b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = reactotron-v1
+ pkgdesc = Package archlinux for Reactotron
+ pkgver = 1.15.0
+ pkgrel = 1
+ url = https://github.com/infinitered/reactotron
+ arch = x86_64
+ license = GPL
+ makedepends = unzip
+ source = https://github.com/infinitered/reactotron/releases/download/v1.15.0/Reactotron-linux-x64.zip
+ source = reactotron-v1.png
+ source = reactotron-v1.desktop
+ sha256sums = 06cb8ce707da5b1d6492be39862889c954f268b6ad5d672ebe0d213d39b7c7da
+ sha256sums = d933e27778d417a633975f22b2cdc2b6d8d922bffab916c92fc08062a7621896
+ sha256sums = 4287b8a022b1c59bdb3ff06dc0e056a6d1ac1779cf1adc33d5b6da61b86cbf9e
+
+pkgname = reactotron-v1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1796265f7de5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=reactotron-v1
+pkgver=1.15.0
+pkgrel=1
+pkgdesc="Package archlinux for Reactotron"
+arch=('x86_64')
+url="https://github.com/infinitered/reactotron"
+license=('GPL')
+groups=()
+depends=()
+makedepends=("unzip")
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/infinitered/reactotron/releases/download/v$pkgver/Reactotron-linux-x64.zip"
+ "reactotron-v1.png"
+ "reactotron-v1.desktop")
+sha256sums=('06cb8ce707da5b1d6492be39862889c954f268b6ad5d672ebe0d213d39b7c7da'
+ "d933e27778d417a633975f22b2cdc2b6d8d922bffab916c92fc08062a7621896"
+ "4287b8a022b1c59bdb3ff06dc0e056a6d1ac1779cf1adc33d5b6da61b86cbf9e")
+
+package() {
+ cd $srcdir
+ install -d $pkgdir/{opt/$pkgname,usr/bin}
+ cp -a Reactotron/* $pkgdir/opt/$pkgname
+ install -Dm644 $srcdir/reactotron-v1.png $pkgdir/usr/share/pixmaps/$pkgname.png
+ install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ ln -s /opt/reactotron-v1/Reactotron $pkgdir/usr/bin/$pkgname
+}
diff --git a/reactotron-v1.desktop b/reactotron-v1.desktop
new file mode 100644
index 000000000000..cf0d810420ab
--- /dev/null
+++ b/reactotron-v1.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.15.0
+Type=Application
+Name=Reactotron-v1
+Exec=/opt/reactotron-v1/Reactotron %f
+Icon=reactotron-v1
+Comment=Reactotron IDE
+Categories=Development;IDE;
+Terminal=false
diff --git a/reactotron-v1.png b/reactotron-v1.png
new file mode 100644
index 000000000000..e8cc841c56b1
--- /dev/null
+++ b/reactotron-v1.png
Binary files differ