summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCTech2017-01-18 10:48:06 +1100
committerCTech2017-01-18 10:48:06 +1100
commit9d2f39d769f148563d7d7920add885493173def8 (patch)
treee1e584dd8bbd23beeaeec49a86646d790774607f
parentf429ed0d241740bc359c6cfa1989dabb602d0558 (diff)
downloadaur-9d2f39d769f148563d7d7920add885493173def8.tar.gz
Fix a build issue with greater than 4 CPU Cores by limiting the number of CPU Cores that can be used to 4
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bc5d441a873..291b514f47cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Jan 16 19:34:25 UTC 2017
+# Tue Jan 17 23:47:40 UTC 2017
pkgbase = reaver-wps-fork-t6x-git
pkgdesc = reaver-wps-fork-t6x is a community forked version of reaver, which has included various bug fixes and additional attack method (the offline Pixie Dust attack).
pkgver = 1.5.2.r201.707c574
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/t6x/reaver-wps-fork-t6x
arch = arm
arch = armv6h
diff --git a/PKGBUILD b/PKGBUILD
index 24fbb42fae16..5d795b3b62de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=reaver-wps-fork-t6x-git
_pkgname=reaver-wps-fork-t6x
pkgver=1.5.2.r201.707c574
-pkgrel=1
+pkgrel=2
pkgdesc="reaver-wps-fork-t6x is a community forked version of reaver, which has included various bug fixes and additional attack method (the offline Pixie Dust attack)."
arch=('arm' 'armv6h' 'armv7h' 'i686' 'x86_64')
url="https://github.com/t6x/reaver-wps-fork-t6x"
@@ -32,9 +32,15 @@ pkgver() {
}
build() {
+ unset MAKEFLAGS
+ cpuCores=$(grep -c ^processor /proc/cpuinfo)
+ if [ "$cpuCores" -gt 4 ]; then
+ cpuCores=4
+ fi
+ echo "Building with $cpuCores CPU Cores"
cd "$pkgname/src"
- ./configure --prefix=/usr --sysconfdir=/etc
- make
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make -j$cpuCores
}
package() {