summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorderwinlu2015-10-04 18:55:44 +0200
committerderwinlu2015-10-04 18:55:44 +0200
commit864a298f80dea4126a933641365c5afd2f05e912 (patch)
tree69a5e926b083a1d796a8b878ca13e9f76373f15c
parent1b754ac096ef9184b77bc6de5673152c72a956d0 (diff)
downloadaur-864a298f80dea4126a933641365c5afd2f05e912.tar.gz
fix build error if not done in a git repository
Upstream expects the build to be done in a git repository as it fetches it's version from the most recent git tag. This can be circumvented by using the version of the PKGBUILD instead.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 605acdbdbcdd..2092c9541b0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rebar3
pkgdesc = A sophisticated build-tool for Erlang projects that follows OTP principles.
pkgver = 3.0.0_beta.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/rebar/rebar3
arch = any
license = APACHE
diff --git a/PKGBUILD b/PKGBUILD
index 0cd9f3c14b6c..f4bd93b692de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=rebar3
_pkgver=3.0.0-beta.3
pkgver=${_pkgver//-/_}
-pkgrel=1
+pkgrel=2
pkgdesc="A sophisticated build-tool for Erlang projects that follows OTP principles."
arch=('any')
url="https://github.com/rebar/rebar3"
@@ -15,6 +15,7 @@ md5sums=('1347cba97461c96dbace6954cd388cf3')
build() {
cd "$srcdir/$pkgname-$_pkgver"
+ sed -i s/\"git\"/\"${_pkgver}\"/ src/rebar.app.src
./bootstrap
}