summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim Baz2018-11-06 00:48:27 +0100
committerMaxim Baz2018-11-06 00:48:27 +0100
commit4279d763ba89690de6a5e85b79b917748e8bb04c (patch)
treed283ca8626e3c4917106196521f1d53654371cc1
parent3f607fe2b6965a28ca0058eed142ff0cf90f6c9b (diff)
downloadaur-4279d763ba89690de6a5e85b79b917748e8bb04c.tar.gz
rebuild-detector: add license
-rw-r--r--.SRCINFO4
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD9
3 files changed, 30 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 555c696f2a2d..23c211963752 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = rebuild-detector
pkgdesc = Detects which packages need to be rebuilt
pkgver = 2.1.0
- pkgrel = 1
+ pkgrel = 2
arch = any
license = MIT
depends = parallel
source = checkrebuild
source = checkrebuild.sig
+ source = LICENSE
validpgpkeys = EB4F9E5A60D32232BB52150C12C87A28FEAC6B20
sha256sums = 52d160787fd11d3aafba0102297353f4ed8751437a6ba72d353958b49420c212
sha256sums = SKIP
+ sha256sums = 4db14647c2d687192ad26c2d4dbc7f2fd03136c3dee67720ebbbbb6c3ebc1d4e
pkgname = rebuild-detector
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..ee08e2252409
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2018 Maxim Baz
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 3194ec7d41e6..fad9658dc678 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,22 @@
pkgname=rebuild-detector
pkgver=2.1.0
-pkgrel=1
+pkgrel=2
pkgdesc='Detects which packages need to be rebuilt'
arch=('any')
license=('MIT')
depends=('parallel')
source=('checkrebuild'
- 'checkrebuild.sig')
+ 'checkrebuild.sig'
+ 'LICENSE')
sha256sums=('52d160787fd11d3aafba0102297353f4ed8751437a6ba72d353958b49420c212'
- 'SKIP')
+ 'SKIP'
+ '4db14647c2d687192ad26c2d4dbc7f2fd03136c3dee67720ebbbbb6c3ebc1d4e')
validpgpkeys=('EB4F9E5A60D32232BB52150C12C87A28FEAC6B20')
package() {
install -Dm755 -t "$pkgdir/usr/bin" checkrebuild
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}
# vim:set ts=4 sw=4 et: