summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsxe2015-06-23 10:52:49 +0200
committersxe2015-06-23 10:52:49 +0200
commit997878c992704aa12c755dfdf0b5efc697df62c2 (patch)
treea85f43be7401582948f9e6b725e7c663934ddc36
downloadaur-recollrunner.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
-rw-r--r--gcc.patch18
-rw-r--r--recollrunner.install6
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f24142b9a4a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = recollrunner
+ pkgdesc = Simple, down-and-dirty Recoll plugin for Krunner.
+ pkgver = 0.6
+ pkgrel = 1
+ url = http://opendesktop.org/content/show.php?content=128203
+ install = recollrunner.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = make
+ makedepends = automoc4
+ depends = kdebase-workspace
+ depends = recoll
+ source = http://opendesktop.org/CONTENT/content-files/128203-recollrunner-0.6.tar.bz2
+ source = gcc.patch
+ md5sums = 3826a01e5864b96bc170426bc3d3f370
+ md5sums = 76525e7bd3ea371d5a98d2e632e5367f
+
+pkgname = recollrunner
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7ecfab5cfd8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: sxe (sxxe@gmx.de)
+
+pkgname=recollrunner
+pkgver=0.6
+pkgrel=1
+pkgdesc="Simple, down-and-dirty Recoll plugin for Krunner."
+arch=('i686' 'x86_64')
+url="http://opendesktop.org/content/show.php?content=128203"
+depends=('kdebase-workspace' 'recoll')
+makedepends=('cmake' 'make' 'automoc4')
+install=$pkgname.install
+source=(http://opendesktop.org/CONTENT/content-files/128203-$pkgname-$pkgver.tar.bz2
+ gcc.patch)
+license=('GPL')
+
+build() {
+
+ msg2 "Patching..."
+ (
+ cd "$srcdir"
+ patch < gcc.patch
+ )
+
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` ..
+ make VERBOSE=1
+ make DESTDIR=$pkgdir install
+}
+
+md5sums=('3826a01e5864b96bc170426bc3d3f370'
+ '76525e7bd3ea371d5a98d2e632e5367f')
diff --git a/gcc.patch b/gcc.patch
new file mode 100644
index 000000000000..25bfa5acc074
--- /dev/null
+++ b/gcc.patch
@@ -0,0 +1,18 @@
+--- recollViewer.cpp 2011-12-09 08:55:23.000000000 +0100
++++ recollViewer.cpp_patched 2012-05-29 10:35:01.090153257 +0200
+@@ -12,7 +12,7 @@
+
+ #include <kicon.h>
+ #include <krun.h>
+-#include <qt4/QtCore/qstringlist.h>
++#include <QtCore/qstringlist.h>
+
+ #include "recollViewer.h"
+ #include "cmdstrings.h"
+@@ -445,4 +445,4 @@
+ }
+ }
+
+-#include "recollViewer.moc"
+\ No newline at end of file
++#include "recollViewer.moc"
diff --git a/recollrunner.install b/recollrunner.install
new file mode 100644
index 000000000000..7b70f85e7be2
--- /dev/null
+++ b/recollrunner.install
@@ -0,0 +1,6 @@
+post_install() {
+ echo "Run kbuildsycoca4 as user to refresh KDE plasma settings."
+}
+post_upgrade() {
+ echo "Run kbuildsycoca4 as user to refresh KDE plasma settings."
+}