summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2019-09-03 15:14:50 +0200
committerKr1ss2019-09-03 15:14:50 +0200
commit8e58b41d8b38c8ed60d3842377b70f73819fa6af (patch)
tree31382e59de248b5073414b468429b9ed17b361c4
parent7eeeca64b39711f192d1ec05d4ddf0f2af6af7bb (diff)
downloadaur-8e58b41d8b38c8ed60d3842377b70f73819fa6af.tar.gz
remove locale patch due to upstream fix
-rw-r--r--.SRCINFO6
-rw-r--r--ISSUES4
-rw-r--r--PKGBUILD9
-rw-r--r--archlinux.patch15
4 files changed, 8 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb676ebca40c..0f7e7f9c82e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = reddio-git
pkgdesc = A command-line interface for Reddit written in POSIX sh
- pkgver = r134.66c12ce
- pkgrel = 3
+ pkgver = r141.8abd41c
+ pkgrel = 1
url = https://gitlab.com/aaronNG/reddio
changelog = ISSUES
arch = any
@@ -16,7 +16,7 @@ pkgbase = reddio-git
source = git+https://gitlab.com/aaronNG/reddio
source = archlinux.patch
sha256sums = SKIP
- sha256sums = d56a36a70ea279778a60e8b827c80166189584dce54bdeeccb8f33a047419157
+ sha256sums = caf1b8d24a8427e3de0abdb4a25fa986f2493eaea9df250c144431ce9274edfa
pkgname = reddio-git
diff --git a/ISSUES b/ISSUES
index 47f7ed266172..b575b11f8ed8 100644
--- a/ISSUES
+++ b/ISSUES
@@ -1,7 +1,3 @@
-Currently it's not possible to load more comments. The Reddit API adds
-the "more" item which has a list of item ids as attribute and they can
-only be acquired by using the "morechildren" endpoint.
-
Private message threads aren't indented properly because the Reddit API
doesn't provide a "depth" attribute for messages. For now, all messages
which have a parent are set to depth 1.
diff --git a/PKGBUILD b/PKGBUILD
index 1c435060ce57..169d034a4e9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@ pkgver() {
cd "${pkgname%-git}"
printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-pkgver=r134.66c12ce
-pkgrel=3
+pkgver=r141.8abd41c
+pkgrel=1
pkgdesc='A command-line interface for Reddit written in POSIX sh'
arch=('any')
@@ -23,7 +23,8 @@ makedepends=('git')
changelog=ISSUES
source=("git+$url" 'archlinux.patch')
-sha256sums=('SKIP' 'd56a36a70ea279778a60e8b827c80166189584dce54bdeeccb8f33a047419157')
+sha256sums=('SKIP'
+ 'caf1b8d24a8427e3de0abdb4a25fa986f2493eaea9df250c144431ce9274edfa')
prepare() {
cd "${pkgname%-git}"
@@ -36,7 +37,7 @@ prepare() {
package() {
cd "${pkgname%-git}"
make PREFIX="$pkgdir/usr" install
- install -Dm644 README.md ISSUES example.png -t"$pkgdir/usr/share/doc/${pkgname%-git}/"
+ install -Dm644 README.md ISSUES example.png doc/* -t"$pkgdir/usr/share/doc/${pkgname%-git}/"
install -Dm644 LICENSE -t"$pkgdir/usr/share/licenses/${pkgname%-git}/"
}
diff --git a/archlinux.patch b/archlinux.patch
index bacb90a4ca22..2baf5f9e77a0 100644
--- a/archlinux.patch
+++ b/archlinux.patch
@@ -10,18 +10,3 @@ diff -ur old/reddio new/reddio
# Make sure the lib directory can be found
[ -d "$lib_dir" ] \
-diff -ur old/share/reddio/pretty-time.sh new/share/reddio/pretty-time.sh
---- old/share/reddio/pretty-time.sh 2019-08-24 14:59:37.992753822 +0200
-+++ new/share/reddio/pretty-time.sh 2019-08-24 15:00:26.673348916 +0200
-@@ -41,9 +41,9 @@
- # Fractions greater than 95 will round up to a whole number
- # We do not want to show the .0
- elif [ "$_frac" -gt 95 ]; then
-- printf '%.0f %ss ago\n' $_int.$_frac $2
-+ LC_NUMERIC=C printf '%.0f %ss ago\n' $_int.$_frac $2
- # Everything else is shown with one decimal
- else
-- printf '%.1f %ss ago\n' $_int.$_frac $2
-+ LC_NUMERIC=C printf '%.1f %ss ago\n' $_int.$_frac $2
- fi
- }