summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author小雨2015-06-12 10:47:37 +0800
committer小雨2015-06-12 10:47:37 +0800
commit24283b8404fd1ce47e7cc6181447a7e96b1655b1 (patch)
treef69a2b0b514ac7c274f1c3ac45394c60e73faf6e
downloadaur-redis-dns-git.tar.gz
init commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
-rw-r--r--package.install3
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ddc60321e46b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = redis-dns-git
+ pkgdesc = A gevent redis based DNS server with dyndns like API (forked from https://github.com/coagentpai/redis-dns)
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/rains31/redis-dns
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = redis
+ depends = python2-daemon
+ depends = python2-dnspython
+ depends = python2-gevent
+ depends = python2-redis
+ provides = redis-dns
+ conflicts = redis-dns
+ source = git+https://github.com/rains31/redis-dns.git
+ sha1sums = SKIP
+
+pkgname = redis-dns-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..442d3eb92f58
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname=redis-dns-git
+_pkgname=redis-dns
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="A gevent redis based DNS server with dyndns like API (forked from https://github.com/coagentpai/redis-dns)"
+url="https://github.com/rains31/redis-dns"
+license=('GPL2')
+depends=('redis' 'python2-daemon' 'python2-dnspython' 'python2-gevent' 'python2-redis')
+makedepends=('git')
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+options=()
+arch=('i686' 'x86_64')
+source=("git+https://github.com/rains31/${_pkgname}.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --tags | sed 's/^v//;s/-/./g'
+}
+
+
+package() {
+ cd "${_pkgname}"
+ #make DESTDIR="$pkgdir" install
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/lib/${_pkgname}"
+ ln -s ../lib/${_pkgname}/${_pkgname} "${pkgdir}/usr/bin/"
+ install -D -m755 "${srcdir}/${_pkgname}/${_pkgname}" "${pkgdir}/usr/lib/${_pkgname}"
+ install -D -m644 ${srcdir}/${_pkgname}/*.py "${pkgdir}/usr/lib/${_pkgname}"
+ install -D -m644 "${srcdir}/${_pkgname}/${_pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${_pkgname}.service"
+}
diff --git a/package.install b/package.install
new file mode 100644
index 000000000000..7c52f76b49db
--- /dev/null
+++ b/package.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo 'please see https://github.com/rains31/redis-dns for more info.'
+}