summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-05-01 19:38:30 +0000
committerAntonio Rojas2020-05-01 19:38:30 +0000
commit69db84a9ab3e2f9d648a5c79acbfee7a18af473c (patch)
treecf68598aaac69ede7674c9fe7ffdd037c49ff44b
downloadaur-remacs.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD67
2 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c2fc527a321
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = remacs
+ pkgdesc = Emacs with parts of it written in Rust
+ pkgver = 0.1
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/remacs/remacs
+ arch = x86_64
+ license = GPL
+ makedepends = cargo
+ makedepends = clang
+ makedepends = git
+ makedepends = rustup
+ makedepends = setconf
+ depends = gnutls
+ depends = gpm
+ depends = libxml2
+ source = git+https://github.com/remacs/remacs#tag=0.1
+ sha256sums = SKIP
+
+pkgname = remacs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a654798ddeb3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+# Contributor: Chris Nixon <chris.nixon@sigma.me.uk>
+
+pkgname=remacs
+pkgver=0.1
+pkgrel=1
+epoch=1
+pkgdesc='Emacs with parts of it written in Rust'
+arch=(x86_64)
+url='https://github.com/remacs/remacs'
+license=(GPL)
+depends=(gnutls gpm libxml2)
+makedepends=(cargo clang git rustup setconf)
+source=("git+https://github.com/remacs/remacs#tag=$pkgver")
+sha256sums=('SKIP')
+
+prepare() {
+ cd $pkgname
+
+ ./autogen.sh
+
+ # Use full path to remacs and remacsclient
+ setconf etc/remacs.service ExecStart '/usr/bin/remacs --fg-daemon'
+ setconf etc/remacs.service ExecStop '/usr/bin/remacsclient --eval "(kill-emacs)"'
+}
+
+build() {
+ cd $pkgname
+
+ export LC_ALL=C
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --with-sound=no \
+ --with-modules \
+ --without-xft \
+ --without-gconf \
+ --without-gsettings \
+ --without-cairo \
+ --without-xwidgets \
+ --without-makeinfo \
+ --without-x \
+ --enable-link-time-optimization
+ make
+}
+
+package() {
+ make -C "$pkgname" DESTDIR="$pkgdir" install-strip
+
+ # avoid conflicts with other packages
+ rm "$pkgdir/usr/"{bin/{ctags,etags,ebrowse},share/man/man1/{ctags,etags,ebrowse}.1.gz}
+ mv "$pkgdir/usr/share/man/man1/"{e,re}macs.1.gz
+ mv "$pkgdir/usr/share/man/man1/"{e,re}macsclient.1.gz
+ rm -r "$pkgdir/usr/share/info"
+
+ # skip /var/games, /usr/share/pixmaps and /usr/share/applications
+ rm -rf "$pkgdir/"{var/games,usr/share/{pixmaps,applications}}
+
+ # fix permissions
+ find "$pkgdir"/usr/share/remacs/ -exec chown root:root {} \;
+}
+
+# vim: ts=2 sw=2 et: