summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2020-05-18 16:52:06 +0200
committerPhilip Goto2020-05-18 16:52:06 +0200
commitb43c1c64ac0d93ba48a5b98421c67f2a2d39b968 (patch)
treecc27996be90b48b1106a163b47e1a1db89c386bb
parentfe727d0ba2220695eed605e19608b19805bb73bc (diff)
downloadaur-remotely-git.tar.gz
Update url, desc and check
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD32
2 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3093d42e5e60..fdac7668b285 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = remotely-git
- pkgdesc = A GTK3 VNC Client
+ pkgdesc = simple VNC viewer for the GNOME desktop environment
pkgver = 1.0.r10.g8792370
- pkgrel = 1
- url = https://gitlab.gnome.org/haecker-felix/Remotely
+ pkgrel = 2
+ url = https://gitlab.gnome.org/World/Remotely
arch = i686
arch = x86_64
- arch = armv6h
arch = armv7h
+ arch = aarch64
license = GPL3
makedepends = git
makedepends = meson
@@ -14,7 +14,7 @@ pkgbase = remotely-git
depends = gtk-vnc
provides = remotely
conflicts = remotely
- source = git+https://gitlab.gnome.org/haecker-felix/Remotely.git
+ source = git+https://gitlab.gnome.org/World/Remotely.git
md5sums = SKIP
pkgname = remotely-git
diff --git a/PKGBUILD b/PKGBUILD
index eb8fb7f62f3a..4ba979685bc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,17 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
-_pkgname=remotely
-pkgname=$_pkgname-git
+pkgname=remotely-git
pkgver=1.0.r10.g8792370
-pkgrel=1
-pkgdesc="A GTK3 VNC Client"
-arch=('i686' 'x86_64' 'armv6h' 'armv7h')
-url="https://gitlab.gnome.org/haecker-felix/Remotely"
-license=('GPL3')
-depends=('gtk-vnc')
-makedepends=('git'
- 'meson'
- 'vala')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-source=("git+https://gitlab.gnome.org/haecker-felix/Remotely.git")
+pkgrel=2
+pkgdesc="simple VNC viewer for the GNOME desktop environment"
+arch=(i686 x86_64 armv7h aarch64)
+url="https://gitlab.gnome.org/World/Remotely"
+license=(GPL3)
+depends=(gtk-vnc)
+makedepends=(git meson vala)
+provides=(remotely)
+conflicts=(remotely)
+source=("git+https://gitlab.gnome.org/World/Remotely.git")
md5sums=('SKIP')
pkgver() {
@@ -23,11 +20,14 @@ pkgver() {
}
build() {
- rm -rf build
arch-meson Remotely build
ninja -C build
}
+check() {
+ meson test -C build --print-errorlogs
+}
+
package() {
- DESTDIR="$pkgdir/" ninja -C build install
+ DESTDIR="$pkgdir" meson install -C build
}