summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2020-07-25 14:21:15 +0200
committerEric Engestrom2020-07-25 14:35:26 +0200
commit35b1cdc839575a0374bcc778664e300646f15611 (patch)
treee9553e043ef26aad6ceeeb4051836f6b9539a201
parentdfd96092afbedb793c2e25a6d925e5c71ceb1a4f (diff)
downloadaur-35b1cdc839575a0374bcc778664e300646f15611.tar.gz
use ninja instead of make to run the compilation
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3adf6ed75cfa..3418c485a293 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = renderdoc-git
arch = x86_64
license = MIT
makedepends = cmake
+ makedepends = ninja
makedepends = python
depends = libx11
depends = libxcb
diff --git a/PKGBUILD b/PKGBUILD
index dcc8503a1b2e..8e9131d8221d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="OpenGL and Vulkan debugging tool"
arch=(i686 x86_64)
url="https://github.com/baldurk/renderdoc"
license=("MIT")
-makedepends=("cmake" "python")
+makedepends=("cmake" "ninja" "python")
depends=("libx11" "libxcb" "mesa" "libgl" "qt5-base" "qt5-svg" "qt5-x11extras" "xcb-util-keysyms")
source=("git+https://github.com/baldurk/renderdoc"
"renderdoc.desktop")
@@ -29,13 +29,13 @@ build() {
-DBUILD_VERSION_DIST_CONTACT="https://aur.archlinux.org/packages/renderdoc-git" \
-DBUILD_VERSION_DIST_NAME="Arch" \
-DBUILD_VERSION_DIST_VER="${pkgver}" \
- -B"${srcdir}/renderdoc"/build \
- -H"${srcdir}/renderdoc"
- cmake --build "${srcdir}/renderdoc"/build
+ -S renderdoc -B build \
+ -G Ninja
+ ninja -C build
}
package() {
- make DESTDIR="${pkgdir}" -C "${srcdir}/renderdoc"/build install
+ DESTDIR="$pkgdir" ninja -C build install
install -Dm644 "${srcdir}"/renderdoc.desktop "$pkgdir/usr/share/applications/renderdoc.desktop"
install -Dm644 "${srcdir}"/renderdoc/docs/imgs/logo.png "$pkgdir/usr/share/icons/renderdoc.png"