summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkpcyrd2018-12-12 17:59:41 +0100
committerkpcyrd2018-12-12 17:59:41 +0100
commit915392e21089db2792b7295d002752fe63bff439 (patch)
treefa58b5cabacdf9c94446d81875cbf883d2becd31
parent238d63eb1f812c4b173fbad385f8bf870d3d2899 (diff)
downloadaur-reprotest.tar.gz
Fix license, add libfaketime and generate manpage
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc8c18aaf34d..5a50718b1c65 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,26 @@
pkgbase = reprotest
pkgdesc = Run a process twice and check the output for reproducibility
pkgver = 0.7.8
- pkgrel = 2
+ pkgrel = 3
url = https://salsa.debian.org/reproducible-builds/reprotest
arch = any
- license = GPL2
license = GPL3
depends = python-setuptools
depends = python
depends = python-rstr
+ depends = python-distro
depends = diffoscope
depends = fakeroot
- depends = python-distro
+ depends = libfaketime
+ depends = python-docutils
+ depends = help2man
optdepends = disorderfs: to enable the shuffle-dirents option
optdepends = python-progressbar: to show a progress bar during diffoscope
source = https://salsa.debian.org/reproducible-builds/reproducible-lfs/raw/master/releases/reprotest/reprotest_0.7.8.tar.xz
source = https://salsa.debian.org/reproducible-builds/reproducible-lfs/raw/master/releases/reprotest/reprotest_0.7.8.tar.xz.asc
validpgpkeys = A405E58AB3725B396ED1B85C1318EFAC5FBBDBCE
validpgpkeys = 66AE2B4AFCCF3F52DA184D184B043FCDB9444540
+ validpgpkeys = 8B7868786C33E5C64C4D0A480816B9E18C762BAD
sha512sums = 2f3f6c609c18f184b5c1eacd820f439e10432b2bc31f275838b297ce4b90e2657d1d900486412847b5b7fb7ec1c85eb67c3b8f68518d2da9bfb78a53b08bfccc
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index e654f71766bc..266e6c02907d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,14 @@
pkgname=('reprotest')
pkgver=0.7.8
-pkgrel=2
+pkgrel=3
pkgdesc="Run a process twice and check the output for reproducibility"
arch=('any')
-license=('GPL2' 'GPL3')
+license=('GPL3')
url="https://salsa.debian.org/reproducible-builds/reprotest"
-depends=('python-setuptools' 'python' 'python-rstr' 'diffoscope' 'fakeroot' 'python-distro')
+depends=('python-setuptools' 'python' 'python-rstr' 'python-distro'
+ 'diffoscope' 'fakeroot' 'libfaketime'
+ 'python-docutils' 'help2man')
optdepends=(
'disorderfs: to enable the shuffle-dirents option'
'python-progressbar: to show a progress bar during diffoscope')
@@ -23,9 +25,13 @@ validpgpkeys=("A405E58AB3725B396ED1B85C1318EFAC5FBBDBCE"
build() {
cd "$srcdir/${pkgname}"
python setup.py build
+
+ make -C doc
}
package() {
cd "$srcdir/${pkgname}"
python setup.py install --root="$pkgdir" --optimize=1
+
+ install -Dm644 doc/reprotest.1 "${pkgdir}/usr/share/man/man1/reprotest.1"
}