summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRandy Ramos2017-04-22 12:36:12 -0400
committerRandy Ramos2017-04-22 12:36:12 -0400
commitb42bfcf07b4fdf6f6e3421c563f13e79e1a740cf (patch)
treec46f1845618b830546a9831646db1d68c5941d60
parenta69c78695a4ac2fc56a6a781b04c0bff228367d1 (diff)
downloadaur-b42bfcf07b4fdf6f6e3421c563f13e79e1a740cf.tar.gz
I changed the source to an active fork
I also removed dhcp-responder. All the addtional tools should be accessed via the install directory in /opt/responder
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD36
-rw-r--r--dhcp-responder.sh3
-rw-r--r--responder.sh2
4 files changed, 22 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37175ebd8981..aa36acd863f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = responder
- pkgdesc = A LLMNR and NBT-NS poisoner, with built-in HTTP/SMB/MSSQL/FTP/LDAP rogue authentication server supporting NTLMv1/NTLMv2/LMv2, Extended Security NTLMSSP and Basic HTTP authentication.
- pkgver = 2.3.0
+ pkgdesc = A LLMNR, NBT-NS and MDNS poisoner, with built-in HTTP/SMB/MSSQL/FTP/LDAP rogue authentication server supporting NTLMv1/NTLMv2/LMv2, Extended Security NTLMSSP and Basic HTTP authentication
+ pkgver = 2.3.3.6
pkgrel = 1
- url = https://github.com/SpiderLabs/Responder/
+ url = https://github.com/lgandx/Responder/
arch = any
license = GPL3
makedepends = git
depends = python2
- source = responder::https://github.com/SpiderLabs/responder/archive/v2.3.0.tar.gz
+ source = https://github.com/lgandx/responder/archive/v2.3.3.6.tar.gz
source = responder.sh
- source = dhcp-responder.sh
- sha256sums = 7f11ca5e60f5187280fa45f3d0ddd3bef6d6d08fc48d1f90528ee452f46f6c1f
- sha256sums = 658d17f895ad48a47babf885176a8a4e891219c7fd7d53141a1dbdbbaa0b9374
- sha256sums = a720b7c918c63ed27356f43b788a171729f0d88c42c01a901d64efb17aa92f78
+ sha256sums = 269245554f7d67ebc29c1f7c97f43521cd5c445fddd77f8c1bf733a3b43ca400
+ sha256sums = 3cb8d0c60e3ee5d985e7099eecbf0f0a5e24ffecd17078e8a19558b8f5c40e9a
pkgname = responder
diff --git a/PKGBUILD b/PKGBUILD
index f603951dee73..7dc44146a080 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,29 @@
-# Maintainer: Randy Ramos <rramos1295 at gmail dot com>
+# Maintainer: Randy Ramos <rramos1295 \at\ gmail \dot\ com>
pkgname='responder'
-pkgver=2.3.0
+pkgver=2.3.3.6
pkgrel=1
-pkgdesc='A LLMNR and NBT-NS poisoner, with built-in HTTP/SMB/MSSQL/FTP/LDAP rogue authentication server supporting NTLMv1/NTLMv2/LMv2, Extended Security NTLMSSP and Basic HTTP authentication.'
+pkgdesc='A LLMNR, NBT-NS and MDNS poisoner, with built-in HTTP/SMB/MSSQL/FTP/LDAP rogue authentication server supporting NTLMv1/NTLMv2/LMv2, Extended Security NTLMSSP and Basic HTTP authentication'
arch=('any')
depends=('python2')
makedepends=('git')
-url='https://github.com/SpiderLabs/Responder/'
+url='https://github.com/lgandx/Responder/'
license=('GPL3')
-source=($pkgname::"https://github.com/SpiderLabs/$pkgname/archive/v$pkgver.tar.gz" 'responder.sh' 'dhcp-responder.sh')
-sha256sums=('7f11ca5e60f5187280fa45f3d0ddd3bef6d6d08fc48d1f90528ee452f46f6c1f'
- '658d17f895ad48a47babf885176a8a4e891219c7fd7d53141a1dbdbbaa0b9374'
- 'a720b7c918c63ed27356f43b788a171729f0d88c42c01a901d64efb17aa92f78'
- )
+source=("https://github.com/lgandx/$pkgname/archive/v$pkgver.tar.gz" 'responder.sh')
+sha256sums=('269245554f7d67ebc29c1f7c97f43521cd5c445fddd77f8c1bf733a3b43ca400'
+ '3cb8d0c60e3ee5d985e7099eecbf0f0a5e24ffecd17078e8a19558b8f5c40e9a')
package() {
cd "$srcdir/Responder-$pkgver"
- mkdir -p "$pkgdir"/usr/bin
- mkdir -p "$pkgdir"/usr/share/responder
- mkdir -p "$pkgdir"/usr/share/doc/responder
+ #Install directory and contents
+ install -d "$pkgdir"/opt/responder
+ cp -ar * "$pkgdir"/opt/responder/
- install -Dm644 -t "$pkgdir"/usr/share/doc/responder README.md
+ #Docs
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/responder/README.md
+ install -Dm644 LICENSE "$pkgdir"/usr/share/doc/responder/LICENSE
- rm README.md
-
- cp -a * "$pkgdir"/usr/share/responder
-
- cd "$srcdir"
-
- install -m 755 responder.sh "$pkgdir"/usr/bin/responder
- install -m 755 dhcp-responder.sh "$pkgdir/usr/bin/dhcp-responder"
+ #Script
+ install -Dm755 "$srcdir"/responder.sh "$pkgdir"/usr/bin/responder
}
diff --git a/dhcp-responder.sh b/dhcp-responder.sh
deleted file mode 100644
index f54da2ed10c8..000000000000
--- a/dhcp-responder.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-cd /usr/share/responder/tools
-exec python2 DHCP.py "$@"
diff --git a/responder.sh b/responder.sh
index 7f28311ef213..606172474d6e 100644
--- a/responder.sh
+++ b/responder.sh
@@ -1,3 +1,3 @@
#!/bin/sh
-cd /usr/share/responder
+cd /opt/responder
exec python2 Responder.py "$@"