summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDylan Delgado2022-03-16 14:44:43 -0400
committerDylan Delgado2022-03-16 14:44:43 -0400
commit383af677ec2ce0494799b5581daf64a714ca29c2 (patch)
treeeb59a6b1cd0aa76a972ff3dbc6a52c1daebb2bdf
parent38243343723c14710116479b21635173f07c3fce (diff)
downloadaur-rgepp.tar.gz
New build system, switch to git+https://
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD34
2 files changed, 19 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26e010921c68..e001cc89e1e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = rgepp
pkgdesc = Template-based C++ class library for solving renormaliztion group equations in quantum field theory
- pkgver = r24.1d9b740
+ pkgver = r32.65b23c8
pkgrel = 1
- url = www.github.com/Herren/RGEpp
+ url = https://github.com/Herren/RGEpp
arch = x86_64
license = MIT
makedepends = clang
+ makedepends = cmake
depends = boost
depends = eigen
- source = git://github.com/Herren/RGEpp.git
- source = make.patch
- md5sums = SKIP
+ source = git+https://github.com/Herren/RGEpp.git
md5sums = SKIP
pkgname = rgepp
-
diff --git a/PKGBUILD b/PKGBUILD
index 0d3fc1703eb5..129edc6b7acf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,52 +2,48 @@
pkgname=rgepp
_pkgname=RGEpp
-pkgver=r24.1d9b740
+pkgver=r32.65b23c8
pkgrel=1
pkgdesc="Template-based C++ class library for solving renormaliztion group equations in quantum field theory"
-url="www.github.com/Herren/RGEpp"
+url="https://github.com/Herren/RGEpp"
license=("MIT")
arch=('x86_64')
depends=('boost' 'eigen')
-makedepends=('clang')
+makedepends=('clang' 'cmake')
-source=("git://github.com/Herren/RGEpp.git"
-"make.patch")
-md5sums=("SKIP"
-"SKIP")
+source=("git+https://github.com/Herren/RGEpp.git")
+md5sums=("SKIP")
pkgver() {
cd "$_pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
-cd "${srcdir}/${_pkgname}"
-patch -l -p1 < ../make.patch
-}
+#prepare() {
+#cd "${srcdir}/${_pkgname}"
+#patch -l -p1 < ../make.patch
+#}
build () {
cd "${srcdir}/${_pkgname}"
-make
-make sm_example
-make nsm_example
-make numssm_example
-make thdm_example
-make running_plot
+cmake -B build
+cd build
+make -j all
}
package() {
mkdir -p "${pkgdir}/usr/include/rgepp/"
-cd "${srcdir}/${_pkgname}/examples"
+cd "${srcdir}/${_pkgname}/build/"
install -Dm755 sm_example "${pkgdir}/usr/bin/sm_example"
install -Dm755 nsm_example "${pkgdir}/usr/bin/nsm_example"
install -Dm755 numssm_example "${pkgdir}/usr/bin/numssm_example"
install -Dm755 thdm_example "${pkgdir}/usr/bin/thdm_example"
install -Dm755 running_plot "${pkgdir}/usr/bin/running_plot"
+install -Dm755 landau_example "${pkgdir}/usr/bin/landau_plot"
for i in include models
do
cd "${srcdir}/${_pkgname}/${i}"
echo "Copying from $PWD"
install -Dm644 *.h "${pkgdir}/usr/include/rgepp/"
done
-} \ No newline at end of file
+}