summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuckSoft2020-04-16 00:02:49 +0800
committerDuckSoft2020-04-16 00:02:49 +0800
commit79c4c194c49271eb50c5a6df6207e9d9f69500c2 (patch)
tree27b87d3ce852b98c678e7f91454642527c61ec22
downloadaur-rime-double-pinyin-zrm-ducksoft.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
-rw-r--r--double_pinyin_zrm.schema.yaml129
3 files changed, 173 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ba54bc8a667
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = rime-double-pinyin-zrm-ducksoft
+ pkgdesc = 自然码双拼 佛振方案 for Rime (DuckSoft 移植版)
+ pkgver = 0.15
+ pkgrel = 1
+ arch = x86_64
+ license = GPL3
+ makedepends = librime
+ makedepends = rime-prelude
+ makedepends = rime-essay
+ makedepends = rime-luna-pinyin
+ depends = rime-luna-pinyin
+ provides = rime-double-pinyin-zrm
+ conflicts = rime-double-pinyin-zrm
+ source = double_pinyin_zrm.schema.yaml
+ sha512sums = c4a9bfcd55aa7b6b555de7dbb6d01119d11c15659f6f2764c00ff89e70aac6cc8dae395744cd5464da862ba2310b1c1d1b476f06f7d3112a2acfa66c0c267f7d
+
+pkgname = rime-double-pinyin-zrm-ducksoft
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..feb209835dd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: DuckSoft <realducksoft at gmail dot com>
+pkgname=rime-double-pinyin-zrm-ducksoft
+pkgver=0.15
+pkgrel=1
+pkgdesc='自然码双拼 佛振方案 for Rime (DuckSoft 移植版)'
+arch=('x86_64')
+provides=('rime-double-pinyin-zrm')
+conflicts=('rime-double-pinyin-zrm')
+depends=('rime-luna-pinyin')
+license=('GPL3')
+makedepends=('librime' 'rime-prelude' 'rime-essay' 'rime-luna-pinyin')
+source=('double_pinyin_zrm.schema.yaml')
+sha512sums=('c4a9bfcd55aa7b6b555de7dbb6d01119d11c15659f6f2764c00ff89e70aac6cc8dae395744cd5464da862ba2310b1c1d1b476f06f7d3112a2acfa66c0c267f7d')
+
+prepare() {
+ for _f in $(pacman -Qql rime-prelude rime-essay rime-luna-pinyin | grep -v "/$"); do ln -sf $_f; done
+}
+
+build(){
+ rime_deployer --compile double_pinyin_zrm.schema.yaml
+}
+
+package() {
+ install -Dm644 double_pinyin_zrm.schema.yaml -t "$pkgdir"/usr/share/rime-data/
+ install -Dm644 build/double_pinyin_zrm.{schema.yaml,prism.bin} -t "$pkgdir"/usr/share/rime-data/build/
+}
diff --git a/double_pinyin_zrm.schema.yaml b/double_pinyin_zrm.schema.yaml
new file mode 100644
index 000000000000..b134c678c42e
--- /dev/null
+++ b/double_pinyin_zrm.schema.yaml
@@ -0,0 +1,129 @@
+# Rime schema
+# encoding: utf-8
+
+schema:
+ schema_id: double_pinyin_zrm
+ name: 自然码双拼
+ version: "0.15"
+ author:
+ - 佛振 <chen.sst@gmail.com>
+ description: |
+ 朙月拼音+自然碼雙拼方案。
+switches:
+ - name: ascii_mode
+ reset: 1
+ states: [ 中文, 西文 ]
+ - name: full_shape
+ states: [ 半角, 全角 ]
+ - name: simplification
+ states: [ 漢字, 汉字 ]
+ - name: ascii_punct
+ states: [ 。,, ., ]
+
+engine:
+ processors:
+ - ascii_composer
+ - recognizer
+ - key_binder
+ - speller
+ - punctuator
+ - selector
+ - navigator
+ - express_editor
+ segmentors:
+ - ascii_segmentor
+ - matcher
+ - abc_segmentor
+ - punct_segmentor
+ - fallback_segmentor
+ translators:
+ - punct_translator
+ - reverse_lookup_translator
+ - script_translator
+ filters:
+ - simplifier
+ - uniquifier
+
+speller:
+ alphabet: zyxwvutsrqponmlkjihgfedcba
+ delimiter: " '"
+ algebra:
+ - erase/^xx$/
+ - derive/^([jqxy])u$/$1v/
+ - derive/^([aoe])([ioun])$/$1$1$2/
+ - xform/^([aoe])(ng)?$/$1$1$2/
+ - xform/iu$/Q/
+ - xform/[iu]a$/W/
+ - xform/[uv]an$/R/
+ - xform/[uv]e$/T/
+ - xform/ing$|uai$/Y/
+ - xform/^sh/U/
+ - xform/^ch/I/
+ - xform/^zh/V/
+ - xform/uo$/O/
+ - xform/[uv]n$/P/
+ - xform/i?ong$/S/
+ - xform/[iu]ang$/D/
+ - xform/(.)en$/$1F/
+ - xform/(.)eng$/$1G/
+ - xform/(.)ang$/$1H/
+ - xform/ian$/M/
+ - xform/(.)an$/$1J/
+ - xform/iao$/C/
+ - xform/(.)ao$/$1K/
+ - xform/(.)ai$/$1L/
+ - xform/(.)ei$/$1Z/
+ - xform/ie$/X/
+ - xform/ui$/V/
+ - xform/(.)ou$/$1B/
+ - xform/in$/N/
+ - xlit/QWRTYUIOPSDFGHMJCKLZXVBN/qwrtyuiopsdfghmjcklzxvbn/
+ #- abbrev/^(.).+$/$1/
+
+translator:
+ dictionary: luna_pinyin
+ prism: double_pinyin_zrm
+ preedit_format:
+ - xform/([bpmnljqxy])n/$1in/
+ - xform/(\w)g/$1eng/
+ - xform/(\w)q/$1iu/
+ - xform/([gkhvuirzcs])w/$1ua/
+ - xform/(\w)w/$1ia/
+ - xform/([dtnlgkhjqxyvuirzcs])r/$1uan/
+ - xform/(\w)t/$1ve/
+ - xform/([gkhvuirzcs])y/$1uai/
+ - xform/(\w)y/$1ing/
+ - xform/([dtnlgkhvuirzcs])o/$1uo/
+ - xform/(\w)p/$1un/
+ - xform/([jqx])s/$1iong/
+ - xform/(\w)s/$1ong/
+ - xform/([jqxnl])d/$1iang/
+ - xform/(\w)d/$1uang/
+ - xform/(\w)f/$1en/
+ - xform/(\w)h/$1ang/
+ - xform/(\w)j/$1an/
+ - xform/(\w)k/$1ao/
+ - xform/(\w)l/$1ai/
+ - xform/(\w)z/$1ei/
+ - xform/(\w)x/$1ie/
+ - xform/(\w)c/$1iao/
+ - xform/([dtgkhvuirzcs])v/$1ui/
+ - xform/(\w)b/$1ou/
+ - xform/(\w)m/$1ian/
+ - xform/([aoe])\1(\w)/$1$2/
+ - "xform/(^|[ '])v/$1zh/"
+ - "xform/(^|[ '])i/$1ch/"
+ - "xform/(^|[ '])u/$1sh/"
+ - xform/([jqxy])v/$1u/
+ - xform/([nl])v/$1ü/
+
+punctuator:
+ import_preset: symbols
+
+key_binder:
+ import_preset: default
+
+recognizer:
+ import_preset: default
+ patterns:
+ reverse_lookup: "`[a-z]*'?$"