summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVitalyR2023-06-30 17:53:35 +0800
committerVitalyR2023-06-30 17:53:35 +0800
commit26733b78b1b3dbad87611ce9a4336f6421d5bfd6 (patch)
treed93d32a2775fdb4f235e23338fcdda38ab283af4
parent8d15079b335ea1066ebd56b0606986ca771474c9 (diff)
downloadaur-ripes-git.tar.gz
use gcc12
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54c23f760fab..6911b5a4e0fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = ripes-git
pkgdesc = A graphical processor simulator and assembly editor for the RISC-V ISA
- pkgver = 2.2.3
- pkgrel = 2
+ pkgver = 2.2.6
+ pkgrel = 1
url = https://github.com/mortbopet/Ripes
arch = x86_64
license = MIT
makedepends = cmake
makedepends = git
- depends = qt5-base
- depends = qt5-charts
- source = ripes-git-2.2.3::git+https://github.com/mortbopet/Ripes.git
+ makedepends = gcc12
+ depends = qt6-base
+ depends = qt6-charts
+ source = ripes-git-2.2.6::git+https://github.com/mortbopet/Ripes.git
source = VSRTL::git+https://github.com/mortbopet/VSRTL.git
source = ELFIO::git+https://github.com/serge1/ELFIO.git
source = libelfin::git+https://github.com/mortbopet/libelfin.git
diff --git a/PKGBUILD b/PKGBUILD
index ffd8af63efad..c09831bf53da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
+# Maintainer: VitalyR <vr AT vitalyr DOT com>
# Maintainer: ltoenning <dev@ltoenning.de>
pkgname=ripes-git
-pkgver=2.2.3
-pkgrel=2
+pkgver=2.2.6
+pkgrel=1
pkgdesc="A graphical processor simulator and assembly editor for the RISC-V ISA"
arch=('x86_64')
url="https://github.com/mortbopet/Ripes"
license=('MIT')
-depends=('qt5-base' 'qt5-charts')
-makedepends=('cmake' 'git')
+depends=('qt6-base' 'qt6-charts')
+makedepends=('cmake' 'git' 'gcc12')
source=("${pkgname}-${pkgver}::git+https://github.com/mortbopet/Ripes.git"
@@ -37,7 +38,7 @@ prepare(){
git config submodule.external/ELFIO.url "$srcdir/ELFIO"
git config submodule.external/VSRTL.url "$srcdir/VSRTL"
git config submodule.external/libelfin.url "$srcdir/libelfin"
- git submodule update
+ git -c protocol.file.allow=always submodule update
# Configure git submodules of VSRTL
cd $srcdir/${pkgname}-${pkgver}/external/VSRTL
@@ -45,20 +46,21 @@ prepare(){
git config submodule.external/better-enums.url "$srcdir/better-enums"
git config submodule.external/cereal.url "$srcdir/cereal"
git config submodule.external/Signals.url "$srcdir/Signals"
- git submodule update
+ git -c protocol.file.allow=always submodule update
# Configure git submodules of libelfin
cd $srcdir/${pkgname}-${pkgver}/external/libelfin
git submodule init
git config submodule.external/cpp-mmaplib.url "$srcdir/cpp-mmaplib"
- git submodule update
+ git -c protocol.file.allow=always submodule update
}
build(){
cd $srcdir/${pkgname}-${pkgver}/build
- cmake -DCMAKE_BUILD_TYPE=Release ..
- make -j $(nproc)
+
+ CC=gcc-12 CXX=g++-12 cmake -DCMAKE_BUILD_TYPE=Release ..
+ CC=gcc-12 CXX=g++-12 make -j $(nproc)
}
package(){