summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Nixon2019-01-28 13:57:29 +0000
committerChris Nixon2019-01-28 13:57:29 +0000
commita71a9c6a741aa2fd70fef890fa597a5af0cd0b5c (patch)
tree5ff85510581be80e1596dc4be7f09e4fb0c10b39
parent43bf6a94dd7baf9c5f32f1a9990a0b2d1885ec76 (diff)
downloadaur-a71a9c6a741aa2fd70fef890fa597a5af0cd0b5c.tar.gz
Update PKGBUILD to remove deprecated feature flags and add PCRE2 support
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD15
2 files changed, 6 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 603f96388dcc..7c4a6717f41d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,6 +10,7 @@ pkgbase = ripgrep-git
makedepends = cargo
makedepends = git
makedepends = asciidoc
+ depends = pcre2
provides = ripgrep
conflicts = ripgrep
source = ripgrep-git::git+https://github.com/BurntSushi/ripgrep
diff --git a/PKGBUILD b/PKGBUILD
index 5f8163e0bbaa..97e5b0a23f9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Chris Nixon <chris.nixon@sigma.me.uk>
pkgname=ripgrep-git
-pkgver=0.8.1.r30.34abed5
+pkgver=0.10.0.r72.049354b
pkgrel=1
pkgdesc="A search tool that combines the usability of The Silver Searcher with the raw speed of grep."
arch=('i686' 'x86_64')
@@ -8,26 +8,21 @@ url="https://github.com/BurntSushi/ripgrep"
license=('UNLICENSE' 'MIT')
provides=("ripgrep")
makedepends=('cargo' 'git' 'asciidoc')
+depends=('pcre2')
conflicts=('ripgrep')
source=("$pkgname::git+https://github.com/BurntSushi/ripgrep")
sha1sums=('SKIP')
build() {
- if grep 'avx' /proc/cpuinfo >/dev/null 2>&1; then
- cpufeatures="simd-accel avx-accel"
- else
- cpufeatures="simd-accel"
- fi
-
cd "$pkgname"
if command -v rustup > /dev/null 2>&1; then
RUSTFLAGS="-C target-cpu=native" rustup run nightly \
- cargo build --release --features "$cpufeatures"
+ cargo build --release --features pcre2
elif rustc --version | grep -q nightly; then
RUSTFLAGS="-C target-cpu=native" \
- cargo build --release --features "$cpufeatures"
+ cargo build --release --features pcre2
else
- cargo build --release
+ cargo build --release --features pcre2
fi
}