summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Nixon2017-01-23 13:35:23 +0000
committerChris Nixon2017-01-23 13:35:23 +0000
commitd4b6daa9c93b188b2a563ff9758be9904ef69f35 (patch)
tree8ad98c092ee199740e6db3e2fddbe68fa494e758
parent1633d380418c239ec1ea387eab8a761f84130120 (diff)
downloadaur-d4b6daa9c93b188b2a563ff9758be9904ef69f35.tar.gz
Adjust pkgver function to discard leading [a-zA-z]
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 223317a5cd25..ece06b01fb4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ripgrep-git
pkgdesc = A search tool that combines the usability of The Silver Searcher with the raw speed of grep.
- pkgver = 0.1.17.2.rf5eb36b
+ pkgver = 0.1.2.6.rb678862
pkgrel = 1
url = https://github.com/BurntSushi/ripgrep
arch = i686
@@ -8,6 +8,7 @@ pkgbase = ripgrep-git
license = UNLICENSE
license = MIT
makedepends = cargo
+ makedepends = git
provides = ripgrep
conflicts = ripgrep
source = ripgrep-git::git+https://github.com/BurntSushi/ripgrep
diff --git a/PKGBUILD b/PKGBUILD
index 78f49607b534..debf296b45ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Chris Nixon <chris.nixon@sigma.me.uk>
pkgname=ripgrep-git
-pkgver=0.1.17.2.rf5eb36b
+pkgver=0.1.2.6.rb678862
pkgrel=1
pkgdesc="A search tool that combines the usability of The Silver Searcher with the raw speed of grep."
arch=('i686' 'x86_64')
url="https://github.com/BurntSushi/ripgrep"
license=('UNLICENSE' 'MIT')
provides=("ripgrep")
-makedepends=('cargo')
+makedepends=('cargo' 'git')
conflicts=('ripgrep')
source=("$pkgname::git+https://github.com/BurntSushi/ripgrep")
sha1sums=('SKIP')
@@ -28,7 +28,7 @@ build() {
pkgver() {
cd "$pkgname"
# Get the first part of the latest tag and append the current revision
- echo "$(git describe --long --tags | sed 's/\(^.*\)-.*.*/\1/;s/-/./g').r$(git log --pretty=format:'%h' -n 1)"
+ echo "$(git describe --long --tags | sed 's/^[a-zA-Z]*[.-]*\(.*\)-.*.*/\1/;s/-/./g').r$(git log --pretty=format:'%h' -n 1)"
}
package() {