summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Kline2018-02-16 10:30:58 +0000
committerChris Nixon2018-02-16 10:30:58 +0000
commitdb7f5b76740ba98cf463e76dbebe2d66db356b7c (patch)
treecc9b10bcb3d2c53b6d90f63b6ec9ea25bd075543
parenta1df140bdb93ae4df9abf3bce59b6f58a13b992c (diff)
downloadaur-db7f5b76740ba98cf463e76dbebe2d66db356b7c.tar.gz
Signed-off-by: Chris Nixon <chris.nixon@sigma.me.uk>
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f593d1d028a..f680a2ae9cd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Chris Nixon <chris.nixon@sigma.me.uk>
pkgname=ripgrep-git
-pkgver=0.4.0.r12.b678862
+pkgver=0.8.0.r7.361698b
pkgrel=1
pkgdesc="A search tool that combines the usability of The Silver Searcher with the raw speed of grep."
arch=('i686' 'x86_64')
url="https://github.com/BurntSushi/ripgrep"
license=('UNLICENSE' 'MIT')
provides=("ripgrep")
-makedepends=('cargo' 'git')
+makedepends=('cargo' 'git' 'asciidoc')
conflicts=('ripgrep')
source=("$pkgname::git+https://github.com/BurntSushi/ripgrep")
sha1sums=('SKIP')
@@ -35,7 +35,10 @@ pkgver() {
package() {
cd "$pkgname"
install -Dm755 "target/release/rg" "$pkgdir/usr/bin/rg"
- install -Dm644 "doc/rg.1" "$pkgdir/usr/share/man/man1/rg.1"
+ # The man page is built with asciidoc and placed in
+ # target/release/build/ripgrep-<hash>/out/rg.1.
+ # Fish around the build directory for that.
+ install -Dm644 $(find target/release/build -type f -name rg.1) "$pkgdir/usr/share/man/man1/rg.1"
install -Dm644 "README.md" "$pkgdir/usr/share/doc/ripgrep/README.md"
install -Dm644 "COPYING" "$pkgdir/usr/share/doc/ripgrep/COPYING"
install -Dm644 "LICENSE-MIT" "$pkgdir/usr/share/doc/ripgrep/LICENSE-MIT"