summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Majewski2020-11-24 13:28:53 +0100
committerKevin Majewski2020-11-24 13:28:53 +0100
commit7c67e2275c77c2c272bc56992f7db093783f2a75 (patch)
tree59af8f0d0086a5cd2ebd58b8818c7c1b6e297251
downloadaur-rnnoise-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec604fce0c4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = rnnoise-git
+ pkgdesc = A noise suppression library based on a recurrent neural network.
+ pkgver = r81.90ec41e
+ pkgrel = 1
+ url = https://github.com/xiph/rnnoise
+ arch = i686
+ arch = x86_64
+ license = BSD3
+ provides = rnnoise
+ conflicts = rnnoise
+ source = git+https://github.com/xiph/rnnoise
+ sha512sums = SKIP
+
+pkgname = rnnoise-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70946ecd47f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=rnnoise-git
+_pkgname=rnnoise
+pkgver=r81.90ec41e
+pkgrel=1
+pkgdesc="A noise suppression library based on a recurrent neural network."
+arch=(i686 x86_64)
+url="https://github.com/xiph/rnnoise"
+license=('BSD3')
+provides=('rnnoise')
+conflicts=('rnnoise')
+source=("git+https://github.com/xiph/rnnoise")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $_pkgname
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd $_pkgname
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $_pkgname
+ make DESTDIR="$pkgdir" install
+}