summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2016-07-31 22:42:41 -0400
committerTony Lambiris2016-07-31 22:42:41 -0400
commit4f14620281eb9a6615ded9a894ba54dbeb8a88fd (patch)
treecb60e79e9eaee886178b5b272bef21e6ecf36261
downloadaur-4f14620281eb9a6615ded9a894ba54dbeb8a88fd.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f02a4fa6955
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = rocksdb-lite
+ pkgdesc = Embedded key-value store for fast storage (lite version)
+ pkgver = 4.9
+ pkgrel = 1
+ url = http://rocksdb.org
+ arch = i686
+ arch = x86_64
+ license = BSD
+ checkdepends = python2
+ depends = gperftools
+ depends = zlib
+ depends = bzip2
+ depends = lz4
+ depends = snappy
+ depends = gcc-libs
+ conflicts = rocksdb
+ source = https://github.com/facebook/rocksdb/archive/rocksdb-4.9.zip
+ sha256sums = 31beaca347531440e816293c244f03d32154040f6d5beddf8045d06829053f36
+
+pkgname = rocksdb-lite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29b76c91cc8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Tony Lambiris <tony@criticalstack.com>
+
+pkgname=rocksdb-lite
+pkgver=4.9
+pkgrel=1
+pkgdesc='Embedded key-value store for fast storage (lite version)'
+arch=(i686 x86_64)
+url='http://rocksdb.org'
+license=(BSD)
+depends=(gperftools zlib bzip2 lz4 snappy gcc-libs)
+checkdepends=(python2)
+source=(https://github.com/facebook/rocksdb/archive/rocksdb-$pkgver.zip)
+sha256sums=('31beaca347531440e816293c244f03d32154040f6d5beddf8045d06829053f36')
+
+prepare() {
+ cd rocksdb-rocksdb-$pkgver
+ sed -e 's/\bpython\b/python2/' -i Makefile
+ if [ "$CARCH" == "armv6h" ]; then
+ sed -e 's/-momit-leaf-frame-pointer//' -i Makefile
+ fi
+}
+
+build() {
+ cd rocksdb-rocksdb-$pkgver
+ CFLAGS='-DROCKSDB_LITE' make shared_lib
+}
+
+check() {
+ cd rocksdb-rocksdb-$pkgver
+# The are some tests are broken in 3.6.2 release
+# make check
+}
+
+package() {
+ cd rocksdb-rocksdb-$pkgver
+ install -m755 -D librocksdb.so "$pkgdir"/usr/lib/librocksdb_lite.so
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}