summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2018-07-06 19:35:46 -0400
committerTony Lambiris2018-07-06 19:35:46 -0400
commitd06f7cc96bb0151778cac6ef7c1505da69f8a4e6 (patch)
tree0989fd62d58d145da3790dd4e6b99eb902deec1e
parent2b9e4f74f97362c440399a927b51902ac1b7fe82 (diff)
downloadaur-d06f7cc96bb0151778cac6ef7c1505da69f8a4e6.tar.gz
Version bump
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--fix-compiler-with-gcc-8.1.1.patch13
-rw-r--r--fix-gcc-8-warnings.patch164
4 files changed, 23 insertions, 174 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf45216124f2..63f8ccba00cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rocksdb-lite
pkgdesc = Embedded key-value store for fast storage (lite version)
- pkgver = 5.13.2
+ pkgver = 5.14.2
pkgrel = 1
url = http://rocksdb.org
arch = i686
@@ -14,10 +14,10 @@ pkgbase = rocksdb-lite
depends = snappy
depends = gcc-libs
conflicts = rocksdb
- source = https://github.com/facebook/rocksdb/archive/v5.13.2.zip
- source = fix-gcc-8-warnings.patch
- sha256sums = 870b6e72a7aa91800abeff418be1bf025813df09663a2d06190910bbf4b44ff1
- sha256sums = 2c5d96fbf1638d899da84b4a80ad3c6060b774ed80148f443ae40672d31df9d3
+ source = https://github.com/facebook/rocksdb/archive/v5.14.2.zip
+ source = fix-compiler-with-gcc-8.1.1.patch
+ sha256sums = 15bb12b9492fc2a20c0c4dbd8873703a1b6b620c32708aaaf558b0a4f58feeda
+ sha256sums = 079e9b29bc7174d6a6a6dd50602f9d2a561ea55d42328c75576acd666fe92dd5
pkgname = rocksdb-lite
diff --git a/PKGBUILD b/PKGBUILD
index 816da7a6fddc..fb62a3049cf5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=rocksdb-lite
-pkgver=5.13.2
+pkgver=5.14.2
pkgrel=1
pkgdesc='Embedded key-value store for fast storage (lite version)'
arch=(i686 x86_64)
@@ -11,9 +11,9 @@ depends=(gperftools zlib bzip2 lz4 snappy gcc-libs)
conflicts=(rocksdb)
checkdepends=(python2)
source=(https://github.com/facebook/rocksdb/archive/v$pkgver.zip
- fix-gcc-8-warnings.patch)
-sha256sums=('870b6e72a7aa91800abeff418be1bf025813df09663a2d06190910bbf4b44ff1'
- '2c5d96fbf1638d899da84b4a80ad3c6060b774ed80148f443ae40672d31df9d3')
+ fix-compiler-with-gcc-8.1.1.patch)
+sha256sums=('15bb12b9492fc2a20c0c4dbd8873703a1b6b620c32708aaaf558b0a4f58feeda'
+ '079e9b29bc7174d6a6a6dd50602f9d2a561ea55d42328c75576acd666fe92dd5')
prepare() {
cd rocksdb-$pkgver
@@ -21,7 +21,7 @@ prepare() {
if [ "$CARCH" == "armv6h" ]; then
sed -e 's/-momit-leaf-frame-pointer//' -i Makefile
fi
- patch -Np1 -i ../fix-gcc-8-warnings.patch
+ patch -Np1 -i ../fix-compiler-with-gcc-8.1.1.patch
}
build() {
diff --git a/fix-compiler-with-gcc-8.1.1.patch b/fix-compiler-with-gcc-8.1.1.patch
new file mode 100644
index 000000000000..ef70a4af6719
--- /dev/null
+++ b/fix-compiler-with-gcc-8.1.1.patch
@@ -0,0 +1,13 @@
+diff --git a/util/status.cc b/util/status.cc
+index 319b0d9a4e..fadfa7d65d 100644
+--- a/util/status.cc
++++ b/util/status.cc
+@@ -25,7 +25,7 @@ const char* Status::CopyState(const char* state) {
+ ret = strncpy_s(result, cch, state, cch - 1);
+ assert(ret == 0);
+ #else
+- std::strncpy(result, state, cch - 1);
++ std::strncpy(result, state, cch);
+ #endif
+ return result;
+ }
diff --git a/fix-gcc-8-warnings.patch b/fix-gcc-8-warnings.patch
deleted file mode 100644
index 7b9243623e4b..000000000000
--- a/fix-gcc-8-warnings.patch
+++ /dev/null
@@ -1,164 +0,0 @@
-diff --git a/db/c.cc b/db/c.cc
-index 0f77949d3f..1c32ee69cb 100644
---- a/db/c.cc
-+++ b/db/c.cc
-@@ -1407,23 +1407,24 @@ void rocksdb_writebatch_put_log_data(
- b->rep.PutLogData(Slice(blob, len));
- }
-
-+class H : public WriteBatch::Handler {
-+ public:
-+ void* state_;
-+ void (*put_)(void*, const char* k, size_t klen, const char* v, size_t vlen);
-+ void (*deleted_)(void*, const char* k, size_t klen);
-+ virtual void Put(const Slice& key, const Slice& value) override {
-+ (*put_)(state_, key.data(), key.size(), value.data(), value.size());
-+ }
-+ virtual void Delete(const Slice& key) override {
-+ (*deleted_)(state_, key.data(), key.size());
-+ }
-+};
-+
- void rocksdb_writebatch_iterate(
- rocksdb_writebatch_t* b,
- void* state,
- void (*put)(void*, const char* k, size_t klen, const char* v, size_t vlen),
- void (*deleted)(void*, const char* k, size_t klen)) {
-- class H : public WriteBatch::Handler {
-- public:
-- void* state_;
-- void (*put_)(void*, const char* k, size_t klen, const char* v, size_t vlen);
-- void (*deleted_)(void*, const char* k, size_t klen);
-- virtual void Put(const Slice& key, const Slice& value) override {
-- (*put_)(state_, key.data(), key.size(), value.data(), value.size());
-- }
-- virtual void Delete(const Slice& key) override {
-- (*deleted_)(state_, key.data(), key.size());
-- }
-- };
- H handler;
- handler.state_ = state;
- handler.put_ = put;
-@@ -1668,18 +1669,6 @@ void rocksdb_writebatch_wi_iterate(
- void* state,
- void (*put)(void*, const char* k, size_t klen, const char* v, size_t vlen),
- void (*deleted)(void*, const char* k, size_t klen)) {
-- class H : public WriteBatch::Handler {
-- public:
-- void* state_;
-- void (*put_)(void*, const char* k, size_t klen, const char* v, size_t vlen);
-- void (*deleted_)(void*, const char* k, size_t klen);
-- virtual void Put(const Slice& key, const Slice& value) override {
-- (*put_)(state_, key.data(), key.size(), value.data(), value.size());
-- }
-- virtual void Delete(const Slice& key) override {
-- (*deleted_)(state_, key.data(), key.size());
-- }
-- };
- H handler;
- handler.state_ = state;
- handler.put_ = put;
-@@ -3298,20 +3287,21 @@ void rocksdb_slicetransform_destroy(rocksdb_slicetransform_t* st) {
- delete st;
- }
-
-+struct Wrapper : public rocksdb_slicetransform_t {
-+ const SliceTransform* rep_;
-+ ~Wrapper() { delete rep_; }
-+ const char* Name() const override { return rep_->Name(); }
-+ Slice Transform(const Slice& src) const override {
-+ return rep_->Transform(src);
-+ }
-+ bool InDomain(const Slice& src) const override {
-+ return rep_->InDomain(src);
-+ }
-+ bool InRange(const Slice& src) const override { return rep_->InRange(src); }
-+ static void DoNothing(void*) { }
-+};
-+
- rocksdb_slicetransform_t* rocksdb_slicetransform_create_fixed_prefix(size_t prefixLen) {
-- struct Wrapper : public rocksdb_slicetransform_t {
-- const SliceTransform* rep_;
-- ~Wrapper() { delete rep_; }
-- const char* Name() const override { return rep_->Name(); }
-- Slice Transform(const Slice& src) const override {
-- return rep_->Transform(src);
-- }
-- bool InDomain(const Slice& src) const override {
-- return rep_->InDomain(src);
-- }
-- bool InRange(const Slice& src) const override { return rep_->InRange(src); }
-- static void DoNothing(void*) { }
-- };
- Wrapper* wrapper = new Wrapper;
- wrapper->rep_ = rocksdb::NewFixedPrefixTransform(prefixLen);
- wrapper->state_ = nullptr;
-@@ -3320,19 +3310,6 @@ rocksdb_slicetransform_t* rocksdb_slicetransform_create_fixed_prefix(size_t pref
- }
-
- rocksdb_slicetransform_t* rocksdb_slicetransform_create_noop() {
-- struct Wrapper : public rocksdb_slicetransform_t {
-- const SliceTransform* rep_;
-- ~Wrapper() { delete rep_; }
-- const char* Name() const override { return rep_->Name(); }
-- Slice Transform(const Slice& src) const override {
-- return rep_->Transform(src);
-- }
-- bool InDomain(const Slice& src) const override {
-- return rep_->InDomain(src);
-- }
-- bool InRange(const Slice& src) const override { return rep_->InRange(src); }
-- static void DoNothing(void*) { }
-- };
- Wrapper* wrapper = new Wrapper;
- wrapper->rep_ = rocksdb::NewNoopTransform();
- wrapper->state_ = nullptr;
-diff --git a/memtable/inlineskiplist.h b/memtable/inlineskiplist.h
-index efcb93c85b..d3ee1f70e6 100644
---- a/memtable/inlineskiplist.h
-+++ b/memtable/inlineskiplist.h
-@@ -287,7 +287,7 @@ struct InlineSkipList<Comparator>::Node {
- // next_[0]. This is used for passing data from AllocateKey to Insert.
- void StashHeight(const int height) {
- assert(sizeof(int) <= sizeof(next_[0]));
-- memcpy(&next_[0], &height, sizeof(int));
-+ memcpy(static_cast<void*>(&next_[0]), &height, sizeof(int));
- }
-
- // Retrieves the value passed to StashHeight. Undefined after a call
-@@ -307,30 +307,30 @@ struct InlineSkipList<Comparator>::Node {
- assert(n >= 0);
- // Use an 'acquire load' so that we observe a fully initialized
- // version of the returned Node.
-- return (next_[-n].load(std::memory_order_acquire));
-+ return ((&next_[0] - n)->load(std::memory_order_acquire));
- }
-
- void SetNext(int n, Node* x) {
- assert(n >= 0);
- // Use a 'release store' so that anybody who reads through this
- // pointer observes a fully initialized version of the inserted node.
-- next_[-n].store(x, std::memory_order_release);
-+ (&next_[0] - n)->store(x, std::memory_order_release);
- }
-
- bool CASNext(int n, Node* expected, Node* x) {
- assert(n >= 0);
-- return next_[-n].compare_exchange_strong(expected, x);
-+ return (&next_[0] - n)->compare_exchange_strong(expected, x);
- }
-
- // No-barrier variants that can be safely used in a few locations.
- Node* NoBarrier_Next(int n) {
- assert(n >= 0);
-- return next_[-n].load(std::memory_order_relaxed);
-+ return (&next_[0] - n)->load(std::memory_order_relaxed);
- }
-
- void NoBarrier_SetNext(int n, Node* x) {
- assert(n >= 0);
-- next_[-n].store(x, std::memory_order_relaxed);
-+ (&next_[0] - n)->store(x, std::memory_order_relaxed);
- }
-
- // Insert node after prev on specific level.