summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122024-11-08 07:32:58 +0100
committerwillemw122024-11-08 07:32:58 +0100
commit755645e42b5c71098cbb3eaea823bbacdc36ba99 (patch)
treefaf1bec2c1f06d987252581570bb4ad67d8c690e
parent7a15e920185670df43e1e93a58d33db49e8ae86c (diff)
downloadaur-rofi-lbonn-wayland-git.tar.gz
chore: add cb-util-keysyms
fix: put license under "rofi-lbonn-wayland" directory name style: minor edits
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD32
2 files changed, 22 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc860311aaec..1b185ecb809d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rofi-lbonn-wayland-git
pkgdesc = A window switcher, application launcher and dmenu replacement (fork with Wayland support)
- pkgver = 1.7.5.wayland1.r42.g5d4a3e14
+ pkgver = 1.7.5.wayland3.r50.g2baa809d
pkgrel = 1
url = https://github.com/lbonn/rofi
arch = x86_64
@@ -16,10 +16,13 @@ pkgbase = rofi-lbonn-wayland-git
depends = startup-notification
depends = wayland
depends = xcb-util-cursor
+ depends = xcb-util-keysyms
depends = xcb-util-wm
depends = xcb-util-xrm
optdepends = i3-wm: use as a window switcher
+ provides = rofi-lbonn-wayland
provides = rofi
+ conflicts = rofi-lbonn-wayland
conflicts = rofi
source = rofi-lbonn-wayland-git::git+https://github.com/lbonn/rofi.git#branch=wayland
source = git+https://github.com/sardemff7/libgwater.git
diff --git a/PKGBUILD b/PKGBUILD
index 9f7e4af50d1b..8eea7003602d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,22 +10,27 @@
# Contributor: SanskritFritz (gmail)
pkgname=rofi-lbonn-wayland-git
-pkgver=1.7.5.wayland1.r42.g5d4a3e14
+pkgver=1.7.5.wayland3.r50.g2baa809d
pkgrel=1
pkgdesc='A window switcher, application launcher and dmenu replacement (fork with Wayland support)'
-arch=('x86_64' 'aarch64')
-url='https://github.com/lbonn/rofi'
+#arch=(x86_64)
+arch=(x86_64 aarch64)
+url=https://github.com/lbonn/rofi
license=(MIT)
-depends=('check' 'librsvg' 'libxdg-basedir' 'libxkbcommon-x11' 'startup-notification'
- 'wayland' 'xcb-util-cursor' 'xcb-util-wm' 'xcb-util-xrm')
-makedepends=('git' 'meson' 'wayland-protocols')
+depends=(
+ check librsvg libxdg-basedir libxkbcommon-x11 startup-notification
+ wayland xcb-util-cursor xcb-util-keysyms xcb-util-wm xcb-util-xrm)
+makedepends=(git meson wayland-protocols)
optdepends=('i3-wm: use as a window switcher')
-provides=('rofi')
-conflicts=('rofi')
-source=("$pkgname::git+$url.git#branch=wayland"
- "git+https://github.com/sardemff7/libgwater.git"
- "git+https://github.com/sardemff7/libnkutils.git")
-sha256sums=('SKIP' 'SKIP' 'SKIP')
+provides=("${pkgname%-git}" rofi)
+conflicts=("${pkgname%-git}" rofi)
+source=(
+ "$pkgname::git+$url.git#branch=wayland"
+ "git+https://github.com/sardemff7/libgwater.git"
+ "git+https://github.com/sardemff7/libnkutils.git")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
git -C $pkgname describe --long | sed 's/\([^-]*-g\)/r\1/;s/[-+]/./g'
@@ -52,7 +57,6 @@ check() {
package() {
meson install -C build --destdir="$pkgdir"
- install -Dm644 $pkgname/COPYING -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 $pkgname/COPYING -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
install -Dm755 $pkgname/Examples/*.sh -t "$pkgdir/usr/share/doc/rofi/examples/"
}
-